summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-07 14:18:55 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-07 14:20:02 +1300
commit6520b638af4c576d480a3c6bda21ba9630cee739 (patch)
tree88dbd64b55a292416712a45bed15b13b8d8aecc3 /dev-perl/Class-MakeMethods
parentnet-vpn/wireguard: update URL (diff)
downloadgentoo-6520b638af4c576d480a3c6bda21ba9630cee739.tar.gz
gentoo-6520b638af4c576d480a3c6bda21ba9630cee739.tar.bz2
gentoo-6520b638af4c576d480a3c6bda21ba9630cee739.zip
dev-perl/Class-MakeMethods: Fix broken tests on Perl 5.26 re bug #615120
Closes: https://bugs.gentoo.org/615120 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Class-MakeMethods')
-rw-r--r--dev-perl/Class-MakeMethods/Class-MakeMethods-1.10.0-r1.ebuild3
-rw-r--r--dev-perl/Class-MakeMethods/files/Class-MakeMethods-1.10.0-perl526.patch27
2 files changed, 29 insertions, 1 deletions
diff --git a/dev-perl/Class-MakeMethods/Class-MakeMethods-1.10.0-r1.ebuild b/dev-perl/Class-MakeMethods/Class-MakeMethods-1.10.0-r1.ebuild
index 14eb72e8dc3d..26ee9d48c461 100644
--- a/dev-perl/Class-MakeMethods/Class-MakeMethods-1.10.0-r1.ebuild
+++ b/dev-perl/Class-MakeMethods/Class-MakeMethods-1.10.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -13,4 +13,5 @@ SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 ppc s390 sh sparc x86 ~ppc-aix ~x86-solaris"
IUSE=""
+PATCHES=( "${FILESDIR}/${P}-perl526.patch" )
SRC_TEST="do"
diff --git a/dev-perl/Class-MakeMethods/files/Class-MakeMethods-1.10.0-perl526.patch b/dev-perl/Class-MakeMethods/files/Class-MakeMethods-1.10.0-perl526.patch
new file mode 100644
index 000000000000..90d6954e854f
--- /dev/null
+++ b/dev-perl/Class-MakeMethods/files/Class-MakeMethods-1.10.0-perl526.patch
@@ -0,0 +1,27 @@
+From e9ca634f9d11894aec3236a8166b48b5bd25e582 Mon Sep 17 00:00:00 2001
+From: Slaven Rezic <slaven@rezic.de>
+Date: Wed, 8 Jun 2016 22:47:42 +0200
+Subject: fix for "Unescaped left brace in regex is deprecated" (RT #115108)
+
+Bug: https://rt.cpan.org/Ticket/Display.html?id=115108
+Bug: https://bugs.gentoo.org/615120
+---
+ tests/xemulator/class_methodmaker/Test.pm | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/tests/xemulator/class_methodmaker/Test.pm b/tests/xemulator/class_methodmaker/Test.pm
+index fc37552..4ab84ad 100644
+--- a/tests/xemulator/class_methodmaker/Test.pm
++++ b/tests/xemulator/class_methodmaker/Test.pm
+@@ -48,7 +48,7 @@ sub COUNT_TESTS {
+ open(IN, $file) or die "Can't open $file: $!";
+ while (<IN>) {
+ /^\s*#/ and next;
+- $c += s/(TEST\s{)/$1/g;
++ $c += s/(TEST\s\{)/$1/g;
+ }
+ $c;
+ }
+--
+2.14.1
+