summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-19 14:10:52 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-19 14:13:57 +0200
commitf549575d26c374b78e119f4a2142973746f175f6 (patch)
treef0ddc2b717953d02be2dae18ae4587e034d362b0 /dev-python/networkx
parentapp-emacs/indent-bars: new package, add 0.2 (diff)
downloadgentoo-f549575d26c374b78e119f4a2142973746f175f6.tar.gz
gentoo-f549575d26c374b78e119f4a2142973746f175f6.tar.bz2
gentoo-f549575d26c374b78e119f4a2142973746f175f6.zip
dev-python/networkx: Bump to 3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/networkx')
-rw-r--r--dev-python/networkx/Manifest1
-rw-r--r--dev-python/networkx/networkx-3.2.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/networkx/Manifest b/dev-python/networkx/Manifest
index 686d63d7fefe..b1e625576152 100644
--- a/dev-python/networkx/Manifest
+++ b/dev-python/networkx/Manifest
@@ -1 +1,2 @@
DIST networkx-3.1.tar.gz 2021691 BLAKE2B 002bb00034e06a45298716c86fec4462efe8db8d206e8263d2e4ce0becc9c073aa2856e0c2df2e74d53237be0b02752204c7e387651aa45387781c383dd1f190 SHA512 9d75ecd25020f83c650824e9449e1c53004c13089dccf7424b65787144dfe3d2f638fd5aca1c4a792b165598b44644fda45bf54c49b3af278ddec5e1f669c38e
+DIST networkx-3.2.tar.gz 2072917 BLAKE2B a611973897deb77f39ffca3c5e144abb1016be32f2623939150d0ea7bf2aee04e40430a00fb2ece8d8d16e8360d1da44adb14aa68798fddd1d4d3b5377360ff1 SHA512 f9fdfbe0c716c5cc6cf3f47b44e02bbd8a166724c2ef7044497b01baf468f354123aeac3c032e31293c7eedd762a29f89628cbe2ecfea280cf6012d7b0d9bdfe
diff --git a/dev-python/networkx/networkx-3.2.ebuild b/dev-python/networkx/networkx-3.2.ebuild
new file mode 100644
index 000000000000..04100f44cf2c
--- /dev/null
+++ b/dev-python/networkx/networkx-3.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_FULLY_TESTED=( python3_{10..11} )
+PYTHON_COMPAT=( "${PYTHON_FULLY_TESTED[@]}" )
+
+inherit distutils-r1 multiprocessing optfeature pypi virtualx
+
+DESCRIPTION="Python tools to manipulate graphs and complex networks"
+HOMEPAGE="
+ https://networkx.org/
+ https://github.com/networkx/networkx/
+ https://pypi.org/project/networkx/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="
+ test? (
+ >=dev-python/lxml-4.6[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/matplotlib-3.5[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.11.2[${PYTHON_USEDEP}]
+ ' "${PYTHON_FULLY_TESTED[@]}")
+ )
+"
+
+distutils_enable_tests pytest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # virtx implies nonfatal
+ nonfatal epytest -p xdist -n "$(makeopts_jobs)" --dist=worksteal || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ # those examples use various assets and pre-compressed files
+ docompress -x /usr/share/doc/${PF}/examples
+}
+
+pkg_postinst() {
+ optfeature "recommended dependencies" "dev-python/matplotlib dev-python/numpy dev-python/pandas dev-python/scipy"
+ optfeature "graph drawing and graph layout algorithms" "dev-python/pygraphviz dev-python/pydot"
+ optfeature "YAML format reading and writing" "dev-python/pyyaml"
+ optfeature "shapefile format reading and writing" "sci-libs/gdal[python]"
+ optfeature "GraphML XML format" "dev-python/lxml"
+}