summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-28 04:35:08 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-28 04:41:29 +0200
commit7ed8da8c612549f4873dab933652d6382fb28d3f (patch)
treef872d4fc40568cb838aad89baed33b112d56c38b /dev-python/path-py
parentdev-python/path-py: Remove py2 (diff)
downloadgentoo-7ed8da8c612549f4873dab933652d6382fb28d3f.tar.gz
gentoo-7ed8da8c612549f4873dab933652d6382fb28d3f.tar.bz2
gentoo-7ed8da8c612549f4873dab933652d6382fb28d3f.zip
dev-python/path-py: Bump to 15.0.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/path-py-15.0.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index d1883a315cb9..cbed46aa7a25 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,2 +1,3 @@
DIST path-14.0.1.tar.gz 73830 BLAKE2B 7528f90708423802dbb177309b1a608bf8dd6b8b1563fcf3904a805830b1c53b76866ec8055bb8d4afda4adb88209b789aed90a33916e450748866479cad1889 SHA512 195abf3e70f3e82566653c8a1154047a8ab82b98eda09a2ae38ba8989e382fd3225fb5c772b827be54a3eafa696829afda2a0198d1bef7ee369e6dc40b0bf11c
+DIST path-15.0.0.tar.gz 73642 BLAKE2B 186b77b6571dd878a5b64b575289bb5ee549145ccd0c7b858f99c9e3772cf98f2cc7ff5da759e7fa660296abc49c053a388ad95466c51adccce2162c682c6566 SHA512 e41684c576b959e27258f60c0d8b69719c38a5a7a04d9646089aea91227781573368a08f01230dca831732ae687741d22caf52efd9a481378b8d4e77627fe3a5
DIST path.py-11.5.2.tar.gz 43542 BLAKE2B 6b376eebf5b9197c4a2e23ee25c8261c7a8b9428007a626bc0f7d1be71496f4abf7fc6f11cee628432304e6a684bd690d6895f325981c4dd0092bdf3c4a4a4e3 SHA512 8a76ffd7d369adb4c5cbc25f2a52c5cabe899bf59d248d217fc5a086e45438d9dfe6b65b63aa2c89edd7662a793d213662cd6726d15f5ce49dc6bdaf22425865
diff --git a/dev-python/path-py/path-py-15.0.0.ebuild b/dev-python/path-py/path-py-15.0.0.ebuild
new file mode 100644
index 000000000000..4779263856c0
--- /dev/null
+++ b/dev-python/path-py/path-py-15.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+MY_P="path-${PV}"
+
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # avoid a setuptools_scm dependency
+ sed -e "s/setup_requires = setuptools_scm/version = '${PV}'/" \
+ -i setup.cfg || die
+
+ # disable fancy test deps
+ sed -e 's: --flake8:: ; s: --black:: ; s: --cov:: ; s: --mypy::' \
+ -i pytest.ini || die
+
+ # fragile test for import time
+ sed -i -e 's:test_import_time:_&:' test_path.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ PYTHONPATH=. pytest -vv || die
+}