summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-07 20:53:52 +0100
committerSam James <sam@gentoo.org>2022-10-07 20:57:27 +0100
commit646fae2fa6825c00143fce1143cf4daeed9a7737 (patch)
treec50b7ea13921aa904da92586342f7cebb7361d74 /dev-python/pytest-mpl
parentsys-libs/zlib-ng: mention 'develop' branch upstream (diff)
downloadgentoo-646fae2fa6825c00143fce1143cf4daeed9a7737.tar.gz
gentoo-646fae2fa6825c00143fce1143cf4daeed9a7737.tar.bz2
gentoo-646fae2fa6825c00143fce1143cf4daeed9a7737.zip
dev-python/pytest-mpl: new package, add 0.16.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/pytest-mpl')
-rw-r--r--dev-python/pytest-mpl/Manifest1
-rw-r--r--dev-python/pytest-mpl/metadata.xml13
-rw-r--r--dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild44
3 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/pytest-mpl/Manifest b/dev-python/pytest-mpl/Manifest
new file mode 100644
index 000000000000..1b363eb582cb
--- /dev/null
+++ b/dev-python/pytest-mpl/Manifest
@@ -0,0 +1 @@
+DIST pytest-mpl-0.16.1.tar.gz 663585 BLAKE2B aad171260a10417aab15e7e55115c2fe02aa33dcf8336634281e1a1dad4d1c5ff08293fd9a67be025ec6cbb18c42bc9eb7ccb86275c0fcc7f4bf33a035fc0927 SHA512 64c1689f1698f9223082bc5c6817a1d4f9b413cb193894c23b1e0302254a6358cb3e354ac92ec47677acf460a41d05b2b527c834fd0fbbde04c070b0af8f46e1
diff --git a/dev-python/pytest-mpl/metadata.xml b/dev-python/pytest-mpl/metadata.xml
new file mode 100644
index 000000000000..c9b79fa5f81b
--- /dev/null
+++ b/dev-python/pytest-mpl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">pytest-mpl</remote-id>
+ <remote-id type="github">matplotlib/pytest-mpl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild b/dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild
new file mode 100644
index 000000000000..9db1c3e57234
--- /dev/null
+++ b/dev-python/pytest-mpl/pytest-mpl-0.16.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Facilitate image comparison for Matplotlib figures"
+HOMEPAGE="
+ https://pypi.org/project/pytest-mpl/
+ https://github.com/matplotlib/pytest-mpl
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+"
+
+EPYTEST_DESELECT=(
+ tests/subtests/test_subtest.py::test_default
+ tests/subtests/test_subtest.py::test_html_images_only
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ # disable autoloading plugins in nested pytest calls
+ #local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ # since we disabled autoloading, force loading necessary plugins
+ #local -x PYTEST_PLUGINS=xdist.plugin,xdist.looponfail,pytest_forked
+
+ epytest
+}