summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-06-08 21:34:51 +0200
committerSam James <sam@gentoo.org>2022-06-16 17:30:27 +0100
commitf8cb29c631350465ce220bff3287b681cf62fa07 (patch)
treee89b7e30ef5a38e2b67766267aee8bc07d62435b /dev-python/shiboken2
parentdev-perl/Tk: fix unquoted variable EPREFIX (diff)
downloadgentoo-f8cb29c631350465ce220bff3287b681cf62fa07.tar.gz
gentoo-f8cb29c631350465ce220bff3287b681cf62fa07.tar.bz2
gentoo-f8cb29c631350465ce220bff3287b681cf62fa07.zip
dev-python/shiboken2: fix unquoted variable EPREFIX
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/shiboken2')
-rw-r--r--dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild4
1 files changed, 2 insertions, 2 deletions
diff --git a/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild b/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
index a8732bcfc06c..594d5f6bf09f 100644
--- a/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
+++ b/dev-python/shiboken2/shiboken2-5.15.2-r1.ebuild
@@ -77,7 +77,7 @@ src_prepare() {
# Shiboken2 assumes Vulkan headers live under either "$VULKAN_SDK/include"
# or "$VK_SDK_PATH/include" rather than "${EPREFIX}/usr/include/vulkan".
if use vulkan; then
- sed -i -e 's~\bdetectVulkan(&headerPaths);~headerPaths.append(HeaderPath{QByteArrayLiteral("'${EPREFIX}'/usr/include/vulkan"), HeaderType::System});~' \
+ sed -i -e "s~\bdetectVulkan(&headerPaths);~headerPaths.append(HeaderPath{QByteArrayLiteral(\"${EPREFIX}/usr/include/vulkan\"), HeaderType::System});~" \
ApiExtractor/clangparser/compilersupport.cpp || die
fi
@@ -96,7 +96,7 @@ src_prepare() {
# PySide2 does *NOT* care whether the end user has done so or not, as
# PySide2 unconditionally requires Clang in either case. See also:
# https://bugs.gentoo.org/619490
- sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'${EPREFIX}'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
+ sed -i -e 's~(findClangBuiltInIncludesDir())~(QStringLiteral("'"${EPREFIX}"'/usr/lib/clang/'$(CPP=clang clang-fullversion)'/include"))~' \
ApiExtractor/clangparser/compilersupport.cpp || die
cmake_src_prepare