summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-23 08:53:47 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-23 09:02:26 +0100
commita3ffc021b679bd8793b0ab369876372142be9fdf (patch)
tree353b39fbabdb9e682d4023cb72025f2d5899d0bd /dev-python/texttable
parentnet-misc/rsync: add rrsync USE flag (diff)
downloadgentoo-a3ffc021b679bd8793b0ab369876372142be9fdf.tar.gz
gentoo-a3ffc021b679bd8793b0ab369876372142be9fdf.tar.bz2
gentoo-a3ffc021b679bd8793b0ab369876372142be9fdf.zip
dev-python/texttable: Bump to 1.6.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/texttable-1.6.7.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index aebffb478058..63036e3cf146 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1,2 +1,3 @@
DIST texttable-1.6.4.tar.gz 11611 BLAKE2B a97a9beefc9547fe7487af5b6411effd7391e303a13161d7e1c9304a1b580cf47bb10c8649dfea5c6f8ba05bc6c3fd7595662e8b74b282696d9ee3a110746212 SHA512 300b02f5b682f1c09a3eb5abfd4ee9c724354505a3f9e8f68207fd7d244402f234437807d68b6b526c3d4ade9e527e66c921bcd47a5e86d680698d559da3fe1a
DIST texttable-1.6.5.gh.tar.gz 11720 BLAKE2B e8a1e7c087de92b11954dc657c59d0c2c0b0afc509ab401c54ff9eca0f75952fcb5a0ae96d08241438c369edf820f03e73f76b9b5d9f610455f74e8a7751396e SHA512 63c73cd85be0432d05abde31ef7d7c91efa461b0f7daae3c6f9a29c116771841bbc1b4daf47c8863e32ed001417b96804ece1e976595c527ee5a1f253129028c
+DIST texttable-1.6.7.gh.tar.gz 11698 BLAKE2B e34f5d6b49de379493697638305b428a1921b93ad95902334f8315263657f4570f6c3770f99bd0fbbce7be29c73f9638922f2c0b19df137a9fde425170d3b0e3 SHA512 204dcad0d2438dab8880088d1ea6ab1d0a5d81348294547a6967938bf8e1c27a6c5f91c59c2fe22ce8d1266d7efdb165749e0aebc738644215ab9b1d5a28c419
diff --git a/dev-python/texttable/texttable-1.6.7.ebuild b/dev-python/texttable/texttable-1.6.7.ebuild
new file mode 100644
index 000000000000..a67b50ccc120
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module to create simple ASCII tables"
+HOMEPAGE="
+ https://github.com/foutaise/texttable/
+ https://pypi.org/project/texttable/
+"
+SRC_URI="
+ https://github.com/foutaise/texttable/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}
+
+pkg_postinst() {
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}