summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2022-11-21 08:51:00 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-11-21 08:52:01 +0200
commita72c784dc6d830635fd24db3279ad3890902059b (patch)
tree81aee40169df6498e51e469549bfcedfd61b0b52 /dev-python/texttable
parentdev-tex/latex-beamer: bump to 3.68 (diff)
downloadgentoo-a72c784dc6d830635fd24db3279ad3890902059b.tar.gz
gentoo-a72c784dc6d830635fd24db3279ad3890902059b.tar.bz2
gentoo-a72c784dc6d830635fd24db3279ad3890902059b.zip
dev-python/texttable: add 1.6.5
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/texttable')
-rw-r--r--dev-python/texttable/Manifest1
-rw-r--r--dev-python/texttable/texttable-1.6.5.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/texttable/Manifest b/dev-python/texttable/Manifest
index c1d05a13eca8..aebffb478058 100644
--- a/dev-python/texttable/Manifest
+++ b/dev-python/texttable/Manifest
@@ -1 +1,2 @@
DIST texttable-1.6.4.tar.gz 11611 BLAKE2B a97a9beefc9547fe7487af5b6411effd7391e303a13161d7e1c9304a1b580cf47bb10c8649dfea5c6f8ba05bc6c3fd7595662e8b74b282696d9ee3a110746212 SHA512 300b02f5b682f1c09a3eb5abfd4ee9c724354505a3f9e8f68207fd7d244402f234437807d68b6b526c3d4ade9e527e66c921bcd47a5e86d680698d559da3fe1a
+DIST texttable-1.6.5.gh.tar.gz 11720 BLAKE2B e8a1e7c087de92b11954dc657c59d0c2c0b0afc509ab401c54ff9eca0f75952fcb5a0ae96d08241438c369edf820f03e73f76b9b5d9f610455f74e8a7751396e SHA512 63c73cd85be0432d05abde31ef7d7c91efa461b0f7daae3c6f9a29c116771841bbc1b4daf47c8863e32ed001417b96804ece1e976595c527ee5a1f253129028c
diff --git a/dev-python/texttable/texttable-1.6.5.ebuild b/dev-python/texttable/texttable-1.6.5.ebuild
new file mode 100644
index 000000000000..f756b0158a00
--- /dev/null
+++ b/dev-python/texttable/texttable-1.6.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Module to create simple ASCII tables"
+HOMEPAGE="https://github.com/foutaise/texttable https://pypi.org/project/texttable/"
+SRC_URI="https://github.com/foutaise/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="dev-python/wcwidth[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests.py || die
+}
+
+pkg_postinst() {
+ optfeature "better wrapping of CJK text" dev-python/cjkwrap
+}