summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-02 09:54:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-02 09:56:38 +0100
commit0391a488704912c78c824375761ba3f9c92f7edc (patch)
tree9c0f40c64147fa884880f108de69e3fb4a24c2dc /dev-python/thunarx-python
parentdev-python/pebble: Remove old (diff)
downloadgentoo-0391a488704912c78c824375761ba3f9c92f7edc.tar.gz
gentoo-0391a488704912c78c824375761ba3f9c92f7edc.tar.bz2
gentoo-0391a488704912c78c824375761ba3f9c92f7edc.zip
dev-python/thunarx-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/thunarx-python')
-rw-r--r--dev-python/thunarx-python/Manifest1
-rw-r--r--dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch85
-rw-r--r--dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch27
-rw-r--r--dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild38
4 files changed, 0 insertions, 151 deletions
diff --git a/dev-python/thunarx-python/Manifest b/dev-python/thunarx-python/Manifest
index 052e6af214dd..758751831747 100644
--- a/dev-python/thunarx-python/Manifest
+++ b/dev-python/thunarx-python/Manifest
@@ -1,2 +1 @@
-DIST thunarx-python-0.5.1.tar.bz2 334426 BLAKE2B 59f8e625b10ceeaefffa4b6dde150c32023365e76854c6e77ae2f222b509856353c8d62de26ba4e7b967cfcce1219205923938389fd1714a420bc9e1ac2b12b2 SHA512 0c1d8f20b74a3eb87b3c2c181c6438bc059dff75afdc26cfea19dffb7efe1f14e6a880689f73afcbbcb5922312741df72018e3b9980c4a45426e7a7d4651177f
DIST thunarx-python-0.5.2.tar.bz2 348120 BLAKE2B ddb098857a7411c1ce4dedf8b406cf6583e78f2ca4b012a9e0346c5a7132c40fd9cf279dc5d054ec827028cdc67321a65fab5e9d3912287ea9ed1f0cf4e72248 SHA512 49d009c84d69f0a1938ed6cb46fe04326c7323edecd79f6d9978ce2306fb95f20c901174f1cea31d5e436c85537efcb79c8613be857a3e4143f7b55b895616b6
diff --git a/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch b/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch
deleted file mode 100644
index 21f55c0e6f8e..000000000000
--- a/dev-python/thunarx-python/files/thunarx-python-0.5.1-fno-common.patch
+++ /dev/null
@@ -1,85 +0,0 @@
-Taken from: https://git.xfce.org/bindings/thunarx-python/commit/?id=3037ebe25d5c6ed58699e56b61f657cea3e5a5a6
-Author: Mukundan Ragavan <nonamedotc@gmail.com>
-
---- a/src/thunarx-python-object.c
-+++ b/src/thunarx-python-object.c
-@@ -24,6 +24,7 @@
-
- #include <thunarx/thunarx.h>
-
-+#define NO_IMPORT_PYGOBJECT
- #include <pygobject.h>
-
- #include <string.h>
---- a/src/thunarx-python.c
-+++ b/src/thunarx-python.c
-@@ -30,6 +30,18 @@
- #include "thunarx-python.h"
- #include "thunarx-python-object.h"
-
-+PyTypeObject *_PyGtkWidget_Type;
-+PyTypeObject *_PyThunarxFileInfo_Type;
-+PyTypeObject *_PyThunarxMenuItem_Type;
-+PyTypeObject *_PyThunarxMenu_Type;
-+PyTypeObject *_PyThunarxMenuProvider_Type;
-+PyTypeObject *_PyThunarxPreferencesProvider_Type;
-+PyTypeObject *_PyThunarxPropertyPage_Type;
-+PyTypeObject *_PyThunarxPropertyPageProvider_Type;
-+PyTypeObject *_PyThunarxProviderPlugin_Type;
-+PyTypeObject *_PyThunarxRenamer_Type;
-+PyTypeObject *_PyThunarxRenamerProvider_Type;
-+
- static const GDebugKey thunarx_python_debug_keys[] = {
- {"all", THUNARX_PYTHON_DEBUG_ALL},
- };
---- a/src/thunarx-python.h
-+++ b/src/thunarx-python.h
-@@ -43,37 +43,37 @@ extern ThunarxPythonDebug thunarx_python_debug;
- #define debug_enter_args(x, y) { if (thunarx_python_debug & THUNARX_PYTHON_DEBUG_ALL) \
- g_printf("%s: entered " x "\n", __FUNCTION__, y); }
-
--PyTypeObject *_PyGtkWidget_Type;
-+extern PyTypeObject *_PyGtkWidget_Type;
- #define PyGtkWidget_Type (*_PyGtkWidget_Type)
-
--PyTypeObject *_PyThunarxFileInfo_Type;
-+extern PyTypeObject *_PyThunarxFileInfo_Type;
- #define PyThunarxFileInfo_Type (*_PyThunarxFileInfo_Type)
-
--PyTypeObject *_PyThunarxMenuItem_Type;
-+extern PyTypeObject *_PyThunarxMenuItem_Type;
- #define PyThunarxMenuItem_Type (*_PyThunarxMenuItem_Type)
-
--PyTypeObject *_PyThunarxMenu_Type;
-+extern PyTypeObject *_PyThunarxMenu_Type;
- #define PyThunarxMenu_Type (*_PyThunarxMenu_Type)
-
--PyTypeObject *_PyThunarxMenuProvider_Type;
-+extern PyTypeObject *_PyThunarxMenuProvider_Type;
- #define PyThunarxMenuProvider_Type (*_PyThunarxMenuProvider_Type)
-
--PyTypeObject *_PyThunarxPreferencesProvider_Type;
-+extern PyTypeObject *_PyThunarxPreferencesProvider_Type;
- #define PyThunarxPreferencesProvider_Type (*_PyThunarxPreferencesProvider_Type)
-
--PyTypeObject *_PyThunarxPropertyPage_Type;
-+extern PyTypeObject *_PyThunarxPropertyPage_Type;
- #define PyThunarxPropertyPage_Type (*_PyThunarxPropertyPage_Type)
-
--PyTypeObject *_PyThunarxPropertyPageProvider_Type;
-+extern PyTypeObject *_PyThunarxPropertyPageProvider_Type;
- #define PyThunarxPropertyPageProvider_Type (*_PyThunarxPropertyPageProvider_Type)
-
--PyTypeObject *_PyThunarxProviderPlugin_Type;
-+extern PyTypeObject *_PyThunarxProviderPlugin_Type;
- #define PyThunarxProviderPlugin_Type (*_PyThunarxProviderPlugin_Type)
-
--PyTypeObject *_PyThunarxRenamer_Type;
-+extern PyTypeObject *_PyThunarxRenamer_Type;
- #define PyThunarxRenamer_Type (*_PyThunarxRenamer_Type)
-
--PyTypeObject *_PyThunarxRenamerProvider_Type;
-+extern PyTypeObject *_PyThunarxRenamerProvider_Type;
- #define PyThunarxRenamerProvider_Type (*_PyThunarxRenamerProvider_Type)
-
- #endif /* THUNARX_PYTHON_H */
diff --git a/dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch b/dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch
deleted file mode 100644
index 19ad0886ad52..000000000000
--- a/dev-python/thunarx-python/files/thunarx-python-0.5.1-py38.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 78b24f3bf34c1faafcdc5816856bc9bf1bfaed6f Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Wed, 15 Jul 2020 17:19:34 +0200
-Subject: [PATCH] Fix compilation with python3.8
-
-Based on upstream commit 5f4edd0b657f52619b60e9931340502fa87f49ff,
-stripped off irrelevant changes, made directly in configure.
----
- configure | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure b/configure
-index 9fabaa0..ff2ceae 100755
---- a/configure
-+++ b/configure
-@@ -13557,7 +13557,7 @@ py_lib_name=`basename $py_include_path`
- if test "x$PYTHON_LIBS" = x; then
- PYTHON_CONFIG=`which $PYTHON`-config
- if test -x "$PYTHON_CONFIG"; then
-- PYTHON_LIBS=`$PYTHON_CONFIG --ldflags 2>/dev/null`
-+ PYTHON_LIBS=`$PYTHON_CONFIG --libs --embed 2>/dev/null` || PYTHON_LIBS=`$PYTHON_CONFIG --libs 2>/dev/null`
- else
- PYTHON_LIBS="-L${py_prefix}/lib -lpython${PYTHON_VERSION}"
- fi
---
-2.27.0
-
diff --git a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild b/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
deleted file mode 100644
index c58a1be9dac4..000000000000
--- a/dev-python/thunarx-python/thunarx-python-0.5.1-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
-
-inherit python-single-r1
-
-DESCRIPTION="Python bindings for the Thunar file manager"
-HOMEPAGE="https://goodies.xfce.org/projects/bindings/thunarx-python"
-SRC_URI="https://archive.xfce.org/src/bindings/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="${PYTHON_DEPS}
- >=dev-libs/glib-2.30:2
- >=x11-libs/gtk+-3.20:3
- >=xfce-base/thunar-1.7.0
- $(python_gen_cond_dep '
- >=dev-python/pygobject-3.20:3[${PYTHON_MULTI_USEDEP}]
- ')"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-PATCHES=(
- "${FILESDIR}"/${P}-py38.patch
- "${FILESDIR}"/${P}-fno-common.patch
-)
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -delete || die
-}