summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-06 23:21:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-07 00:07:20 +0100
commitbb521d96bb625806db9218e173d45273c11dd7a6 (patch)
tree27de34ff4729fb7d0fb15894fc3da162d34f35a1 /dev-python/yamlpath
parentapp-admin/awscli: Bump to 1.22.21 (diff)
downloadgentoo-bb521d96bb625806db9218e173d45273c11dd7a6.tar.gz
gentoo-bb521d96bb625806db9218e173d45273c11dd7a6.tar.bz2
gentoo-bb521d96bb625806db9218e173d45273c11dd7a6.zip
dev-python/yamlpath: Bump to 3.6.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/yamlpath')
-rw-r--r--dev-python/yamlpath/Manifest1
-rw-r--r--dev-python/yamlpath/yamlpath-3.6.4.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/yamlpath/Manifest b/dev-python/yamlpath/Manifest
index eed54223b967..852c02355f1e 100644
--- a/dev-python/yamlpath/Manifest
+++ b/dev-python/yamlpath/Manifest
@@ -1,2 +1,3 @@
DIST yamlpath-3.6.1.tar.gz 214053 BLAKE2B 5c72ffc4e4307f1a3fea7a697782c432402acc1ee929de34a702188d51287fd7187b688354533163b7101dc17ed394f0e2681a1a194807f00762bf6c71387292 SHA512 8ef8e1931118ed881d52b6d7f589b1c671694c211cb1c988e7e6945b7ff5408163bd402f52c1815b453bf8ccc61e8b8ed5c19a00be076d8e76e0a037461a12e2
DIST yamlpath-3.6.3.gh.tar.gz 214734 BLAKE2B fd36d276831771c81272a2bb60a9fe7995c63f1026143925e34167ee397b56725ec9ba5d5afac2a85121512b8f8da3f988fd022dc2378ee80b91567f15d95c1a SHA512 b6c41b550339809e3a0bcbd7dca190956f06799303c1c12bb68eed567c56ccafd2acc2a8a6ab33fb03abde61b3de25673ee2d459f6d66e6782f9325212653ade
+DIST yamlpath-3.6.4.gh.tar.gz 216016 BLAKE2B fc6537b7c80ecfb9f69c646970e43935374bb105df007c123cf837eb1de6827ac2cc443294b69500c966ea6bc5d7f56498aec13340238c7660118f17cc6685e5 SHA512 eb1ac0d5861818f4f4b57b07f9fa7f758846982abbb3ac4ec58a1adaca8ec36deba1e21ce3e13916e74a946512f4d66e341a9d45392ef7133d0293e5fd6f66c9
diff --git a/dev-python/yamlpath/yamlpath-3.6.4.ebuild b/dev-python/yamlpath/yamlpath-3.6.4.ebuild
new file mode 100644
index 000000000000..aee7c4907046
--- /dev/null
+++ b/dev-python/yamlpath/yamlpath-3.6.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Command-line processors for YAML/JSON/Compatible data."
+HOMEPAGE="https://github.com/wwkimball/yamlpath https://github.com/wwkimball/yamlpath/wiki"
+SRC_URI="
+ https://github.com/wwkimball/yamlpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/ruamel-yaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-console-scripts[${PYTHON_USEDEP}]
+ dev-ruby/hiera-eyaml
+ )
+"
+
+distutils_enable_tests --install pytest
+
+python_prepare_all() {
+ sed -e '/ruamel\.yaml/d' \
+ -e '/pytest-cov/d' \
+ -e "/find_packages/s/()/(exclude=\['tests'\])/" \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # install and optimize yamlpath/patches/aliasstyle.py
+ local sitedir=$(python_get_sitedir)
+ [[ -d ${D}${sitedir} ]] || die "${D}${sitedir}: No such directory"
+ insinto "${sitedir}/yamlpath"
+ doins -r "${S}/yamlpath/patches"
+ python_optimize "${D}${sitedir}"
+}