summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-08 21:27:55 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-08 21:27:55 +0200
commite06ada5af0d9c807e22960a98365e5424408b128 (patch)
tree29dab4ed2574525f5d0457686b0414568c9159a5 /dev-python
parentdev-python/snakeoil: (live) bump minimal flit_core (diff)
downloadgentoo-e06ada5af0d9c807e22960a98365e5424408b128.tar.gz
gentoo-e06ada5af0d9c807e22960a98365e5424408b128.tar.bz2
gentoo-e06ada5af0d9c807e22960a98365e5424408b128.zip
dev-python/snakeoil: add 0.10.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/snakeoil/Manifest1
-rw-r--r--dev-python/snakeoil/snakeoil-0.10.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/snakeoil/Manifest b/dev-python/snakeoil/Manifest
index 20aa5f3f73d9..e36d66a80565 100644
--- a/dev-python/snakeoil/Manifest
+++ b/dev-python/snakeoil/Manifest
@@ -1 +1,2 @@
DIST snakeoil-0.10.1.tar.gz 176054 BLAKE2B bd056911c993d274d6c0c79ee4660629d8a6b8c276835a1b29bea16f977907b76a5edebe142b168b282fce3baa9c97b465233d91f5a279fba26a2c04aec0c784 SHA512 9e16652663dab1bd88f620a4fb80ca6602a181d4738a34bef89116f962a2035988cf9fb036b6a12de39b05a5251ade0e933b1df63c020b900338a89169619397
+DIST snakeoil-0.10.2.tar.gz 178557 BLAKE2B 2bdbb99cb6c9aab3f491895d4f4f51b47484a36cb97b3e41240b7b72b9918c0a85b9ad0f8cf977e5f9a2b618f1ca50535d5c7290626807dd78d1ab2fa0b9c24e SHA512 9b0e124faef00840e0a21ff8b1632bdfb15b5c03c7305e65cc7b709e57a55060c65094d6c978ec1b3f6677e6bf0f22aba6036eb7d1c434a32f64242c1a008f33
diff --git a/dev-python/snakeoil/snakeoil-0.10.2.ebuild b/dev-python/snakeoil/snakeoil-0.10.2.ebuild
new file mode 100644
index 000000000000..50e5f7ee3893
--- /dev/null
+++ b/dev-python/snakeoil/snakeoil-0.10.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
+ inherit git-r3
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="misc common functionality and useful optimizations"
+HOMEPAGE="https://github.com/pkgcore/snakeoil"
+
+LICENSE="BSD BSD-2 MIT"
+SLOT="0"
+
+RDEPEND="
+ dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/flit_core-3.8[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest