summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-05 15:20:12 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-05 15:21:38 +0100
commit2ca2b246395c9aefc12891a0c508943cff984d70 (patch)
tree089efdcc259355d1af473ae1798a67a58bcef330 /dev-python
parentsys-apps/cpuid: drop 20221003 (diff)
downloadgentoo-2ca2b246395c9aefc12891a0c508943cff984d70.tar.gz
gentoo-2ca2b246395c9aefc12891a0c508943cff984d70.tar.bz2
gentoo-2ca2b246395c9aefc12891a0c508943cff984d70.zip
dev-python/nbconvert: Fix install failure on Prefix
Closes: https://bugs.gentoo.org/882027 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/nbconvert/nbconvert-7.1.0.ebuild7
-rw-r--r--dev-python/nbconvert/nbconvert-7.2.7.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/dev-python/nbconvert/nbconvert-7.1.0.ebuild b/dev-python/nbconvert/nbconvert-7.1.0.ebuild
index dd3b2ac768ae..1e3fe58b3c49 100644
--- a/dev-python/nbconvert/nbconvert-7.1.0.ebuild
+++ b/dev-python/nbconvert/nbconvert-7.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -59,7 +59,10 @@ src_prepare() {
}
python_configure() {
- cp "${BROOT}$(python_get_sitedir)/notebook/static/style/style.min.css" \
+ local src=$(
+ "${EPYTHON}" -c "import notebook as m; print(*m.__path__)" || die
+ )
+ cp "${src}/static/style/style.min.css" \
share/templates/classic/static/style.css || die
}
diff --git a/dev-python/nbconvert/nbconvert-7.2.7.ebuild b/dev-python/nbconvert/nbconvert-7.2.7.ebuild
index b5df64f0bc51..80dfa912fb98 100644
--- a/dev-python/nbconvert/nbconvert-7.2.7.ebuild
+++ b/dev-python/nbconvert/nbconvert-7.2.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -59,7 +59,10 @@ src_prepare() {
}
python_configure() {
- cp "${BROOT}$(python_get_sitedir)/notebook/static/style/style.min.css" \
+ local src=$(
+ "${EPYTHON}" -c "import notebook as m; print(*m.__path__)" || die
+ )
+ cp "${src}/static/style/style.min.css" \
share/templates/classic/static/style.css || die
}