summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-24 18:22:38 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-24 18:22:38 +0100
commit68293075c1f4377c8f08102eadba6f0903a8c44d (patch)
tree49528566df16d4a7a57292918dff3364e6dc934e /dev-python
parentdev-python/patsy: Remove old (diff)
downloadgentoo-68293075c1f4377c8f08102eadba6f0903a8c44d.tar.gz
gentoo-68293075c1f4377c8f08102eadba6f0903a8c44d.tar.bz2
gentoo-68293075c1f4377c8f08102eadba6f0903a8c44d.zip
dev-python/selenium: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/selenium/Manifest2
-rw-r--r--dev-python/selenium/selenium-4.15.2.ebuild63
2 files changed, 0 insertions, 65 deletions
diff --git a/dev-python/selenium/Manifest b/dev-python/selenium/Manifest
index c83a3f08dd26..54e606f7e15f 100644
--- a/dev-python/selenium/Manifest
+++ b/dev-python/selenium/Manifest
@@ -1,4 +1,2 @@
-DIST selenium-4.15.2.tar.gz 9954413 BLAKE2B 93f17b7d952f63eb8f2f119398e4dbfe9d850a1b2a2f959a6ee63014aa6a40570782ade4891ae75350ca4e530f0b0c249e3849bedf81b2a3c173e670508c0f46 SHA512 ea716702033426e66ce85a91a00f2c6f24091430304de6b419b99a5ea9ce9fad319ccbf9ea826e440d1b4a333c31c1e39978d82eae066e8b1d13bb312a8669a6
DIST selenium-4.16.0.tar.gz 9741404 BLAKE2B 13b24b883ff6d276164ed845405e70c0267506656ce4ee63f0653e409e3c70fd8d3aa2bc1a551d051ea0c95f0bb6b60b5474caefd69e0bddfc97d1cbf9aabbcf SHA512 86aea8f4a23b9e70de36c3024cf5eee32f4d44a6868bd98eda547d9ca51179b4618c6c408e0d0a658c621de2573e98b3d8093753a9c335986a287e00fb3238c8
-DIST selenium-selenium-4.15.2-python.gh.tar.gz 78937488 BLAKE2B 9d064e5f753bdecc7ebab65b5c37cd433c05bf3c7ab09007247290bc782b9e64ec58bd499c838eb51c880c6ace258fef487fa6fb46c334230c5e6f64748014dd SHA512 9f1259b6f1362be5089766d4f51c20defc8f3e8c4a1be25690f9ed8acdccb0c09f64a0cdf0fe871956fb76cb2038663b7f99e620e302f89420fb582a6171fa92
DIST selenium-selenium-4.16.0.gh.tar.gz 77969888 BLAKE2B efc9b444762eb8921d35a2ed1b86c197d314a2e5d65fd430ff996735acf0c1dc03c25a9300946d98230a87f1eed4c0260ec57238f49853b6461a1f0cbeb3e151 SHA512 05cf76bb6df21f32a04485c4a1180d02f028ecb5c49f5f680bcdcc9711ca9f407a6e2d6754708cf2023ca6a19910a411711393892a741bc1f658496bbc809ac2
diff --git a/dev-python/selenium/selenium-4.15.2.ebuild b/dev-python/selenium/selenium-4.15.2.ebuild
deleted file mode 100644
index 24ecc80372cd..000000000000
--- a/dev-python/selenium/selenium-4.15.2.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 pypi
-
-# upstream sometimes tags it as ${P}, sometimes as ${P}-python, sigh
-TEST_TAG=${P}-python
-TEST_P=selenium-${TEST_TAG}
-
-DESCRIPTION="Python language binding for Selenium Remote Control"
-HOMEPAGE="
- https://www.seleniumhq.org/
- https://github.com/SeleniumHQ/selenium/tree/trunk/py/
- https://pypi.org/project/selenium/
-"
-SRC_URI+="
- test? (
- https://github.com/SeleniumHQ/selenium/archive/${TEST_TAG}.tar.gz
- -> ${TEST_P}.gh.tar.gz
- )
-"
-
-KEYWORDS="amd64 arm arm64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-LICENSE="Apache-2.0"
-SLOT="0"
-
-RDEPEND="
- >=dev-python/certifi-2021.10.8[${PYTHON_USEDEP}]
- <dev-python/trio-1[${PYTHON_USEDEP}]
- >=dev-python/trio-0.17[${PYTHON_USEDEP}]
- <dev-python/trio-websocket-1[${PYTHON_USEDEP}]
- >=dev-python/trio-websocket-0.9[${PYTHON_USEDEP}]
- <dev-python/urllib3-3[${PYTHON_USEDEP}]
- >=dev-python/urllib3-1.26[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO: we may need extra setup or deps
- test/selenium
-
- # expects vanilla certifi
- test/unit/selenium/webdriver/remote/remote_connection_tests.py::test_get_connection_manager_for_certs_and_timeout
- )
-
- cd "${WORKDIR}/${TEST_P}/py" || die
- rm -rf selenium || die
- # https://github.com/SeleniumHQ/selenium/blob/selenium-4.8.2-python/py/test/runner/run_pytest.py#L20-L24
- # seriously?
- epytest -o "python_files=*_tests.py test_*.py"
-}