summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-08-07 15:56:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2018-08-07 17:48:55 +0200
commitf598f3fbbec85764c740e712fe1630a1ee912b2a (patch)
tree818cdb06f87908696b471fbe59a2f4f2c9e8753e /dev-ros/qt_dotgraph/qt_dotgraph-0.3.10.ebuild
parentros-meta/ros_comm: Bump to 1.14.3. (diff)
downloadgentoo-f598f3fbbec85764c740e712fe1630a1ee912b2a.tar.gz
gentoo-f598f3fbbec85764c740e712fe1630a1ee912b2a.tar.bz2
gentoo-f598f3fbbec85764c740e712fe1630a1ee912b2a.zip
dev-ros/qt_dotgraph: Bump to 0.3.10.
Package-Manager: Portage-2.3.44, Repoman-2.3.10
Diffstat (limited to 'dev-ros/qt_dotgraph/qt_dotgraph-0.3.10.ebuild')
-rw-r--r--dev-ros/qt_dotgraph/qt_dotgraph-0.3.10.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ros/qt_dotgraph/qt_dotgraph-0.3.10.ebuild b/dev-ros/qt_dotgraph/qt_dotgraph-0.3.10.ebuild
new file mode 100644
index 000000000000..e833e27d3446
--- /dev/null
+++ b/dev-ros/qt_dotgraph/qt_dotgraph-0.3.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros-visualization/qt_gui_core"
+KEYWORDS="~amd64"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Helpers to work with dot graphs"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/pydot[${PYTHON_USEDEP}]
+ >=dev-ros/python_qt_binding-0.3.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pygraphviz[${PYTHON_USEDEP}]
+ )"