summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-03-11 20:22:44 +0100
committerMatt Turner <mattst88@gentoo.org>2020-03-15 14:28:38 -0700
commit54cd2d8449481778c58c772867a77011364b4715 (patch)
tree5555f684a14fd6067afaa6c040019be4f8520c10 /dev-util
parentdev-util/vulkan-tools: python3_8 (diff)
downloadgentoo-54cd2d8449481778c58c772867a77011364b4715.tar.gz
gentoo-54cd2d8449481778c58c772867a77011364b4715.tar.bz2
gentoo-54cd2d8449481778c58c772867a77011364b4715.zip
dev-util/vulkan-tools: Drop USE vulkaninfo
Unconditionally build it: No additional deps, tiny, fine with wayland. Package-Manager: Portage-2.3.93, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/vulkan-tools/vulkan-tools-9999.ebuild20
1 files changed, 8 insertions, 12 deletions
diff --git a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
index d00a6b3086a0..e4065eb7f9cb 100644
--- a/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
+++ b/dev-util/vulkan-tools/vulkan-tools-9999.ebuild
@@ -23,11 +23,9 @@ HOMEPAGE="https://github.com/KhronosGroup/Vulkan-Tools"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="+cube +vulkaninfo wayland +X"
+IUSE="+cube wayland +X"
-# Vulkaninfo does not support wayland
-REQUIRED_USE="|| ( X wayland )
- vulkaninfo? ( X )"
+REQUIRED_USE="|| ( X wayland )"
BDEPEND="${PYTHON_DEPS}
>=dev-util/cmake-3.10.2
@@ -46,11 +44,9 @@ DEPEND="${RDEPEND}
"
pkg_setup() {
- MULTILIB_CHOST_TOOLS=()
-
- if use vulkaninfo; then
- MULTILIB_CHOST_TOOLS+=( /usr/bin/vulkaninfo )
- fi
+ MULTILIB_CHOST_TOOLS=(
+ /usr/bin/vulkaninfo
+ )
if use cube; then
MULTILIB_CHOST_TOOLS+=(
@@ -65,8 +61,8 @@ pkg_setup() {
multilib_src_configure() {
local mycmakeargs=(
-DCMAKE_SKIP_RPATH=ON
+ -DBUILD_VULKANINFO=ON
-DBUILD_CUBE=$(usex cube)
- -DBUILD_VULKANINFO=$(usex vulkaninfo)
-DBUILD_WSI_WAYLAND_SUPPORT=$(usex wayland)
-DBUILD_WSI_XCB_SUPPORT=$(usex X)
-DBUILD_WSI_XLIB_SUPPORT=$(usex X)
@@ -77,8 +73,8 @@ multilib_src_configure() {
# Upstream only supports one window system at a time
# If X is set at all, even if wayland is set, use X
#
- # If -cube and/or -vulkaninfo is set, the flags we set
- # are ignored, so we don't need to consider that
+ # If -cube is set, the flags we set are ignored,
+ # so we don't need to consider that
if use X; then
mycmakeargs+=(
-DCUBE_WSI_SELECTION="XCB"