summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-util/higan-purify/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-util/higan-purify/files')
-rw-r--r--games-util/higan-purify/files/higan-purify-03-QA.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-util/higan-purify/files/higan-purify-03-QA.patch b/games-util/higan-purify/files/higan-purify-03-QA.patch
new file mode 100644
index 000000000000..e523ba4cad95
--- /dev/null
+++ b/games-util/higan-purify/files/higan-purify-03-QA.patch
@@ -0,0 +1,42 @@
+--- purify_v03-source/purify/Makefile
++++ purify_v03-source/purify/Makefile
+@@ -2,8 +2,8 @@
+ include phoenix/Makefile
+
+ path := /usr/local/bin
+-flags := -I. -O3 -fomit-frame-pointer
+-link := -s
++flags := -I. $(CXXFLAGS)
++link := $(LDFLAGS)
+ objects := obj/phoenix.o obj/purify.o
+
+ ifeq ($(platform),x)
+@@ -22,7 +22,7 @@
+
+ build: $(objects)
+ ifeq ($(platform),x)
+- $(cpp) -pthread $(link) -o purify $(objects) $(phoenixlink)
++ $(cpp) $(flags) -pthread $(link) -o purify $(objects) $(phoenixlink)
+ else ifeq ($(platform),win)
+ windres phoenix/windows/phoenix.rc obj/phoenix-resource.o
+ $(cpp) -shared -o phoenix.dll obj/phoenix.o $(phoenixlink)
+--- purify_v03-source/purify/phoenix/Makefile
++++ purify_v03-source/purify/phoenix/Makefile
+@@ -4,13 +4,13 @@
+ endif
+
+ ifeq ($(phoenix),gtk)
+- phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0`
+- phoenixlink := `pkg-config --libs gtk+-2.0`
++ phoenixflags := -DPHOENIX_GTK `pkg-config --cflags gtk+-2.0 x11`
++ phoenixlink := `pkg-config --libs gtk+-2.0 x11` -ldl
+ endif
+
+ ifeq ($(phoenix),qt)
+- phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui`
+- phoenixlink := `pkg-config --libs QtCore QtGui`
++ phoenixflags := -DPHOENIX_QT `pkg-config --cflags QtCore QtGui x11`
++ phoenixlink := `pkg-config --libs QtCore QtGui x11` -ldl
+ endif
+ else ifeq ($(platform),win)
+ phoenixflags := -DPHOENIX_WINDOWS