summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-25 14:08:15 +0000
committerSam James <sam@gentoo.org>2024-11-25 14:08:15 +0000
commit6b08dc8612d1754f708055e723fae68e077304f2 (patch)
treed13d618af4e4cac414e50c450a46a24a2676eaa0 /gnome-extra
parentsys-fs/compsize: add upstream PR link to patch (diff)
downloadgentoo-6b08dc8612d1754f708055e723fae68e077304f2.tar.gz
gentoo-6b08dc8612d1754f708055e723fae68e077304f2.tar.bz2
gentoo-6b08dc8612d1754f708055e723fae68e077304f2.zip
gnome-extra/libgda: fix C23 compat
Closes: https://bugs.gentoo.org/944755 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/libgda/files/libgda-5.2.9-c23.patch33
-rw-r--r--gnome-extra/libgda/libgda-5.2.9-r2.ebuild3
2 files changed, 36 insertions, 0 deletions
diff --git a/gnome-extra/libgda/files/libgda-5.2.9-c23.patch b/gnome-extra/libgda/files/libgda-5.2.9-c23.patch
new file mode 100644
index 000000000000..a2e2a950b084
--- /dev/null
+++ b/gnome-extra/libgda/files/libgda-5.2.9-c23.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/944755
+https://gitlab.gnome.org/GNOME/libgda/-/issues/272
+https://gitlab.gnome.org/GNOME/libgda/-/merge_requests/208
+
+From 333dc9252e022a70f7a820aa63318ddd15edca83 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ahmed=20Ba=C3=AFzid?= <ahmed.baizid.0@gmail.com>
+Date: Sat, 31 Aug 2024 22:18:56 +0100
+Subject: [PATCH] error: function declaration without prototype
+
+Function declaration with no prototype are forbidden in C23.
+
+See: https://www.open-std.org/jtc1/sc22/wg14/www/docs/n2841.htm
+
+Closes #272.
+--- a/libgda/sql-parser/lemon.c
++++ b/libgda/sql-parser/lemon.c
+@@ -57,14 +57,6 @@ struct action;
+ static struct action *Action_new(void);
+ static struct action *Action_sort(struct action *);
+
+-/********** From the file "build.h" ************************************/
+-void FindRulePrecedences();
+-void FindFirstSets();
+-void FindStates();
+-void FindLinks();
+-void FindFollowSets();
+-void FindActions();
+-
+ /********* From the file "configlist.h" *********************************/
+ void Configlist_init(void);
+ struct config *Configlist_add(struct rule *, int);
+--
+GitLab
diff --git a/gnome-extra/libgda/libgda-5.2.9-r2.ebuild b/gnome-extra/libgda/libgda-5.2.9-r2.ebuild
index 00225fd31682..35f2bc52766b 100644
--- a/gnome-extra/libgda/libgda-5.2.9-r2.ebuild
+++ b/gnome-extra/libgda/libgda-5.2.9-r2.ebuild
@@ -113,6 +113,9 @@ src_prepare() {
# https://github.com/gentoo/gentoo/pull/36912#issuecomment-2171657215
eapply "${FILESDIR}/${PN}-5.2.9-fix-gcc14.patch"
+ # bug #944755
+ eapply "${FILESDIR}/${PN}-5.2.9-c23.patch"
+
gnome2_src_prepare
java-pkg-opt-2_src_prepare
}