summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-10-11 08:27:52 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2021-10-11 12:59:06 +0200
commitbb1407a85d47e395a00d170679aaf00da6875f5d (patch)
tree34a52f4f7dc6807ca8a36c14956dad299a6e7ecb /kde-frameworks/frameworkintegration
parentgnome-extra/gnome-shell-frippery: bump to 41.1 (diff)
downloadgentoo-bb1407a85d47e395a00d170679aaf00da6875f5d.tar.gz
gentoo-bb1407a85d47e395a00d170679aaf00da6875f5d.tar.bz2
gentoo-bb1407a85d47e395a00d170679aaf00da6875f5d.zip
kde-frameworks/frameworkintegration: 5.87.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.87.0.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 4bb39885dcfe..8617a19493a5 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.85.0.tar.xz 1755792 BLAKE2B 0a9b6b9a35d20fac0d07cbcf23f4ca1e0627a0175a7298a6b6391b1f4e1c38a46e029dc21ff22ea397ad3de053485097137e5a0de818300000f0c0e4f03c474e SHA512 d496c3b2ff49a3e4ee43e3c208b7dd3df68561fed0fe519f22a163c3389683f7d776270fc6472f4b52677cf85eb4a73c6bb7bdeea951600f8f5302411677a4f3
DIST frameworkintegration-5.86.0.tar.xz 1755804 BLAKE2B f5100b577fc3664d34ae0e62f1c05763eba173595aaf86b7bb073a69c3baa126c7fae34e07e72a541f2da79063ea6cbf101c43294eca65ad545e37a8f2245ed6 SHA512 66a97064a47599e27ec5fc7ac92be87a5c7df31154f662d13bcd21556562b50989b82ab538ae96b7f372a2ee77c408e47ffed62bff1c94c91f8b2b9c786dec69
+DIST frameworkintegration-5.87.0.tar.xz 1756108 BLAKE2B 4ada22086c806988bbd845e2f2b85facad26a14db853e26d86cd4752c894a595d40e8f8b123b2e26d62447bf82cefa474140207b1d7d3d24140038f44a4b6797 SHA512 39d5217e2f537ee31331ae918e7d97242175fbed2f336cf5cf8c78dc7c5fb1ddc5b2f9cc86c78c737ac4fae2edda56be5a7991d6f48ee33fa4d0d13658dfec74
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.87.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.87.0.ebuild
new file mode 100644
index 000000000000..d52fad501353
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.87.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.2
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}