summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-13 10:57:07 -0500
committerMatt Turner <mattst88@gentoo.org>2021-03-13 11:00:01 -0500
commit2a9e45e5f46b478745fe1e7edebdf3d005f77919 (patch)
tree6179eea9cae07e3d9bfe5bf8684f2b918663b1e8 /net-libs/uhttpmock
parentapp-office/libreoffice: Update dependencies (diff)
downloadgentoo-2a9e45e5f46b478745fe1e7edebdf3d005f77919.tar.gz
gentoo-2a9e45e5f46b478745fe1e7edebdf3d005f77919.tar.bz2
gentoo-2a9e45e5f46b478745fe1e7edebdf3d005f77919.zip
net-libs/uhttpmock: Version bump to 0.5.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'net-libs/uhttpmock')
-rw-r--r--net-libs/uhttpmock/Manifest1
-rw-r--r--net-libs/uhttpmock/uhttpmock-0.5.3.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/net-libs/uhttpmock/Manifest b/net-libs/uhttpmock/Manifest
index eaf251c7ed23..168676543c68 100644
--- a/net-libs/uhttpmock/Manifest
+++ b/net-libs/uhttpmock/Manifest
@@ -1 +1,2 @@
DIST uhttpmock-0.5.1.tar.xz 310976 BLAKE2B a7aa609d853a8593461aaaed0074532bc7df1d43638c720694a558cd4eefac14b140f79025cbf7ca9a93ad41cfecfa7728eb049e52d514edda7267389f4d8097 SHA512 99135c0983be78eaaf962e5b182eaaf921e1d6ed30f98691d8766e9d4a9e07188965ce3f546a13a8c32b148bad305083cc3cfdf48d9a8b91efffaec5a46d8006
+DIST uhttpmock-0.5.3.tar.xz 318708 BLAKE2B 7bd257fbc8869ce2d55070bc1f84f0d34c999cd55ba5e09a54031ea391c3c65bb149d48f2ab1ab9de93acac98783ad0e7d5fca4d86dda055d4a5a3407f5ba4ee SHA512 9fccdb58ce04c1615d47bafac275c632f161a8148f0af82447286d0017d6b3946145b8a289f9abb55842bf4610ca3e5f2484bf322fb7a33dce42b3ebed45b2ee
diff --git a/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild b/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild
new file mode 100644
index 000000000000..9178bba643a3
--- /dev/null
+++ b/net-libs/uhttpmock/uhttpmock-0.5.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+GCONF_DEBUG="yes"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala
+
+DESCRIPTION="HTTP web service mocking library"
+HOMEPAGE="https://gitlab.com/uhttpmock/uhttpmock"
+SRC_URI="http://tecnocode.co.uk/downloads/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.38.0:2
+ >=net-libs/libsoup-2.37.91:2.4
+ introspection? ( >=dev-libs/gobject-introspection-0.9.7:= )
+"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+"
+BDEPEND="
+ >=dev-util/gtk-doc-am-1.14
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}