summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-04-12 06:40:07 -0400
committerTim Harder <radhermit@gentoo.org>2017-04-12 06:40:07 -0400
commit9b5d1bdf747a2f3512554e3f4cdc6e52063877bb (patch)
tree3f0df35e980b5e95b17c5128e2e26762a8a3bbaf /net-mail/lbdb
parentmedia-sound/lilypond: version bump to 2.19.59 (diff)
downloadgentoo-9b5d1bdf747a2f3512554e3f4cdc6e52063877bb.tar.gz
gentoo-9b5d1bdf747a2f3512554e3f4cdc6e52063877bb.tar.bz2
gentoo-9b5d1bdf747a2f3512554e3f4cdc6e52063877bb.zip
net-mail/lbdb: version bump to 0.42.1
Diffstat (limited to 'net-mail/lbdb')
-rw-r--r--net-mail/lbdb/Manifest1
-rw-r--r--net-mail/lbdb/lbdb-0.42.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/net-mail/lbdb/Manifest b/net-mail/lbdb/Manifest
index c677c3911b17..a3cec1842a9b 100644
--- a/net-mail/lbdb/Manifest
+++ b/net-mail/lbdb/Manifest
@@ -1,3 +1,4 @@
DIST lbdb_0.39.tar.gz 158802 SHA256 4083ce4abde18ac949ca6eab453b3b7227a5aa2c737c9ad8ecbb0152fabfafc6 SHA512 f37fd3261fa132d6320039f43765624d4eff3508e20f581688222ab9add4f3846c772fdc6d6bb936d572634b78bae0a2403c6bcf034ed19e2d54d95a744cba1e WHIRLPOOL 25bcc1b4fc03acbd7fb13b7e2864f010b8f11e7a2809a7b36eef6af1e81d67ce295a438d6cb52e8171a7e7d9321725d69682c278634382d58974be9cba0ba273
DIST lbdb_0.41.tar.gz 160632 SHA256 83f686fe3ea699b7e67d1c7b4f9aee4930b6b87fb2f5267a221785672d08092b SHA512 c99d8c4549d781252192e07dfb89adbae6daae5a4f4c94de692c4289848ba8599c2b0aeb28bac69313e6828995eac32acf3fbc76b1695c6464c6339236cdb341 WHIRLPOOL 97c1859f738fad87dc38a3d6132974cb6fe4fa2c4d61b0d75cfa237645b1d94d4ea78e20e0b79c148765464ad04a0edf1094d8456bc7d7ffd23d29b2f74929d6
+DIST lbdb_0.42.1.tar.gz 158766 SHA256 d78cc7623108d9b5c4bf33305f3193a8a9955bfbe09b4d3277ad5f54d35ff022 SHA512 50c405bb05e38f5b23b05c27626262680bcacd6385b636a1e6bed0c3cf4c319a1cc19181587e390c04bb2e5b3a275a9e053c42536df6554b6f44d3b8496fabfd WHIRLPOOL e1e2b54beec718bcf45104a921f5a6515b6b3dcc4d21e24406ba6a571c5d020b82d293791ac006cecfa5cc2c126e8193303ae197660d120938b7a3850a8163e8
DIST lbdb_0.42.tar.gz 158714 SHA256 efb0de0d50a4170e7ccfa033e7b38678310b94578309e55e805cca2e06596f53 SHA512 d8d27450fab09ff41e592fb2ef9395b8ed30c2a925136184c0339574f3a58b7e54b5846c722d2e065da5a98b166497e148afd43592f80942cf4aeb35934e91d7 WHIRLPOOL 741ace49bffd4876f1570d9b7ec5eff1c8d6e57f693e0d66f543a5c7efbf0fa80ce80faf85696ddc5b4e95c15f5bb2247be58b68ff227cbc66afdbf69e554e9c
diff --git a/net-mail/lbdb/lbdb-0.42.1.ebuild b/net-mail/lbdb/lbdb-0.42.1.ebuild
new file mode 100644
index 000000000000..48a8974ca10c
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.42.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+LICENSE="GPL-2"
+IUSE="pda ldap finger abook crypt evo"
+
+DEPEND="dev-libs/libvformat
+ evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_configure() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if use evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/$(get_version_component_range 1-2 ${evoversion})/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ --without-ypcat \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --enable-lbdb-dotlock \
+ --without-pgpk --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb
+}
+
+src_install () {
+ emake install_prefix="${D}" install
+ dodoc README TODO debian/changelog
+}