summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Brandt <poncho@spahan.ch>2023-02-20 11:57:38 +0100
committerSam James <sam@gentoo.org>2023-02-22 07:42:21 +0000
commita36725f4578e21e73fda03448f81b0158e5dc9d6 (patch)
tree7cdcd67450aa267dff7963d8c09d7fbaef12037a /net-misc/nyx
parentnet-libs/stem: drop 1.8.0_p20211118 (diff)
downloadgentoo-a36725f4578e21e73fda03448f81b0158e5dc9d6.tar.gz
gentoo-a36725f4578e21e73fda03448f81b0158e5dc9d6.tar.bz2
gentoo-a36725f4578e21e73fda03448f81b0158e5dc9d6.zip
net-misc/nyx: allow net-libs/stem-1.8.1
Signed-off-by: Daniel Brandt <poncho@spahan.ch> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-misc/nyx')
-rw-r--r--net-misc/nyx/nyx-2.1.0-r5.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/nyx/nyx-2.1.0-r5.ebuild b/net-misc/nyx/nyx-2.1.0-r5.ebuild
new file mode 100644
index 000000000000..7a7ed9a92d4f
--- /dev/null
+++ b/net-misc/nyx/nyx-2.1.0-r5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} pypy3 )
+PYTHON_REQ_USE='ncurses,sqlite(-)'
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Utility to monitor real time Tor status information"
+HOMEPAGE="https://nyx.torproject.org"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://git.torproject.org/nyx.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+
+# net-libs/stem-1.8.0_p20211118 was an incompatible git-snapshot
+# simply depend on net-libs/stem in the future
+RDEPEND="
+ || ( <net-libs/stem-1.8.0_p20211118[${PYTHON_USEDEP}] ~net-libs/stem-1.8.1[${PYTHON_USEDEP}] )
+ net-vpn/tor"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # bug #645336
+ doman nyx.1
+}