summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-06-19 18:02:51 -0400
committerMatt Turner <mattst88@gentoo.org>2022-06-19 18:07:14 -0400
commite9a059a2ad803992b283ed535957a387526c6900 (patch)
tree51b199b06c19c070084d10de7b0fc6b97a9d2563 /x11-misc/alacarte
parentsys-kernel/git-sources: add 5.19_rc3 (diff)
downloadgentoo-e9a059a2ad803992b283ed535957a387526c6900.tar.gz
gentoo-e9a059a2ad803992b283ed535957a387526c6900.tar.bz2
gentoo-e9a059a2ad803992b283ed535957a387526c6900.zip
x11-misc/alacarte: Version bump to 3.44.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc/alacarte')
-rw-r--r--x11-misc/alacarte/Manifest1
-rw-r--r--x11-misc/alacarte/alacarte-3.44.2.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/alacarte/Manifest b/x11-misc/alacarte/Manifest
index 2e5d949aca3a..645bbbe99999 100644
--- a/x11-misc/alacarte/Manifest
+++ b/x11-misc/alacarte/Manifest
@@ -1 +1,2 @@
DIST alacarte-3.44.1.tar.xz 253364 BLAKE2B ebd542430f909291d06c1094aac52f87760547013f012167fa5616609251a6cb48b258122424a119b3ab10e6e2289d9a282dd66da3dcf5590b09d9c686a8934b SHA512 84b1cebdcbb53e2cca5a1425829b00db0b2a11e308584ea96179c2d0451d8c77fa6a995ae4671a024fab72869c7d2e9986dc310bfab38fe8b7b2f54d383501ca
+DIST alacarte-3.44.2.tar.xz 253580 BLAKE2B 206eea28b50ef6d0cf228031ff72c16c6ebd130dfa623b96eb727ef62aad3db0003f3a97bc188f4b8a0e9d18cc184a9230fb332131d37afb0abe71dc3d13ee1e SHA512 b62c15ca37717e988b1d64f0ab565970ae15a4bc11a3f31da8574a0b4f10a9cf8b94d0a85be34d871c106ab34c63b2dfbf535b46eb630829e73c14023b99053e
diff --git a/x11-misc/alacarte/alacarte-3.44.2.ebuild b/x11-misc/alacarte/alacarte-3.44.2.ebuild
new file mode 100644
index 000000000000..ec98922c90ce
--- /dev/null
+++ b/x11-misc/alacarte/alacarte-3.44.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Simple GNOME menu editor"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/alacarte"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/pygobject:3[${PYTHON_USEDEP}]')
+ >=gnome-base/gnome-menus-3.5.3:3[introspection]
+"
+RDEPEND="${DEPEND}
+ x11-libs/gdk-pixbuf:2[introspection]
+ x11-libs/gtk+:3[introspection]
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}