summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-01-03 23:34:32 +0100
committerDavid Seifert <soap@gentoo.org>2018-01-04 10:15:41 +0100
commit822e267a6a4c3554502fdf50c82961aee574ea27 (patch)
tree21961c067c430f83883a1a2e899c006a6c1bff5a /x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
parentx11-plugins/gkrellmlaunch: Eclass update (diff)
downloadgentoo-822e267a6a4c3554502fdf50c82961aee574ea27.tar.gz
gentoo-822e267a6a4c3554502fdf50c82961aee574ea27.tar.bz2
gentoo-822e267a6a4c3554502fdf50c82961aee574ea27.zip
x11-plugins/gkrelltop: Eclass update
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild')
-rw-r--r--x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild33
1 files changed, 15 insertions, 18 deletions
diff --git a/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild b/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
index 4e6349415d03..059b7d824e5b 100644
--- a/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
+++ b/x11-plugins/gkrelltop/gkrelltop-2.2.13-r2.ebuild
@@ -1,41 +1,38 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit gkrellm-plugin toolchain-funcs
DESCRIPTION="a GKrellM2 plugin which displays the top three processes"
SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz"
HOMEPAGE="https://sourceforge.net/projects/gkrelltop"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="X"
-PLUGIN_SERVER_SO=gkrelltopd.so
-PLUGIN_SO=gkrelltop.so
-
-S="${WORKDIR}/${P}.orig"
-
RDEPEND="
- app-admin/gkrellm[X]
+ app-admin/gkrellm:2[X]
dev-libs/glib:2
- x11-libs/gtk+:2
-"
+ x11-libs/gtk+:2"
DEPEND="${RDEPEND}"
-src_prepare() {
- sed -i \
- -e "s:/usr/bin/gcc:$(tc-getCC) \$(CFLAGS):" \
- -e 's/-shared/$(LDFLAGS) &/' \
- Makefile || die
- default
+S=${WORKDIR}/${P}.orig
+PATCHES=( "${FILESDIR}"/${PN}-2.2.13-fix-build-system.patch )
+
+PLUGIN_SERVER_SO=( gkrelltopd$(get_modname) )
+PLUGIN_SO=( gkrelltop$(get_modname) )
+
+src_configure() {
+ tc-export CC
}
src_compile() {
- use X || TARGET="server"
- emake ${TARGET}
+ use X || local target="server"
+ emake ${target}
}
pkg_postinst() {