summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-drivers/xf86-video-geode/xf86-video-geode-2.11.20.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/x11-drivers/xf86-video-geode/xf86-video-geode-2.11.20.ebuild b/x11-drivers/xf86-video-geode/xf86-video-geode-2.11.20.ebuild
index 3b9f17e55879..be974bd039dd 100644
--- a/x11-drivers/xf86-video-geode/xf86-video-geode-2.11.20.ebuild
+++ b/x11-drivers/xf86-video-geode/xf86-video-geode-2.11.20.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit xorg-3
DESCRIPTION="AMD Geode GX2 and LX video driver"
@@ -19,8 +20,9 @@ PATCHES=(
"${FILESDIR}"/${P}-fix-multiple-definition-of-linker-error.patch
)
-pkg_setup() {
- XORG_CONFIGURE_OPTIONS=(
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
$(use_enable ztv)
)
+ xorg-3_src_configure
}