summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/texworks')
-rw-r--r--app-editors/texworks/Manifest1
-rw-r--r--app-editors/texworks/texworks-0.6.7.ebuild75
2 files changed, 76 insertions, 0 deletions
diff --git a/app-editors/texworks/Manifest b/app-editors/texworks/Manifest
index eefbc10c4021..c13233cb56ae 100644
--- a/app-editors/texworks/Manifest
+++ b/app-editors/texworks/Manifest
@@ -1,2 +1,3 @@
DIST texworks-0.6.5.tar.gz 12140935 BLAKE2B 660606fe2e53d5f2a53e80792efbee368f5f2f402ab974761efc6e11a6f2233fd04672dcc3bf0155a070162616c1d5a9c7313825890e6fb0c6c4dc7af2c62d29 SHA512 d97bb7c3ad7bbb402be80556027ef19076dae91bb9449df2b45d54e89b492e32b8d6f109d1bda9388424af6218866d84a8c296c9bc2ef644cf2fac0d4b24939e
DIST texworks-0.6.6.tar.gz 12385550 BLAKE2B 241a9e4649e489964c62bd44ca310ffa7d67ebcb6187568dbf5e5b7916d81e3d846f0492a22e35d2c8a57d182d32d129600570e3836c671ae723c236f82d6bd8 SHA512 65300dfbe4e0e2f3b387c868e343f6caeff4602b47afee5a02cce82e0e23b74fe559b4b54fb65d778748de56f38581305a9b3a53d743c957b7dc14ecce4546d1
+DIST texworks-0.6.7.tar.gz 12394465 BLAKE2B 0a2e0531ef0f296cd2be176baed14eb0c21733aeaf3ca3c43e3ff02e48bf68be8953db67f955db0b5a56676b391e2f7700404e9ea52907092d58cbbccaa02adf SHA512 b1c22c1f9bfae2595e77f0c98297cc690f62aac38125bb576d57cc3a0666d779e75af23ccf430a3547215065596b4ea60758233947cda06df8e1a7fc95c46b65
diff --git a/app-editors/texworks/texworks-0.6.7.ebuild b/app-editors/texworks/texworks-0.6.7.ebuild
new file mode 100644
index 000000000000..c0305cb4055c
--- /dev/null
+++ b/app-editors/texworks/texworks-0.6.7.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..3} )
+PYTHON_COMPAT=( python3_{8..11} )
+CMAKE_REMOVE_MODULES_LIST=( FindLua )
+inherit lua-single python-single-r1 cmake virtualx xdg
+
+DESCRIPTION="A simple interface for working with TeX documents"
+HOMEPAGE="http://tug.org/texworks/"
+SRC_URI="https://github.com/TeXworks/texworks/archive/release-${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-release-${PV}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="lua python"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="
+ lua? ( ${LUA_REQUIRED_USE} )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+RDEPEND="app-text/hunspell:=
+ app-text/poppler[qt5]
+ dev-qt/designer:5
+ dev-qt/qtcore:5
+ dev-qt/qtconcurrent:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtscript:5[scripttools]
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ lua? ( ${LUA_DEPS} )
+ python? ( ${PYTHON_DEPS} ) "
+DEPEND="${RDEPEND}"
+BDEPEND="dev-qt/linguist-tools:5
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.5-cmake_lua_version.patch
+)
+
+pkg_setup() {
+ use lua && lua-single_pkg_setup
+
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -Wno-dev
+
+ -DPREFER_BUNDLED_SYNCTEX=ON
+ -DWITH_LUA=$(usex lua)
+ -DWITH_PYTHON=$(usex python)
+ -DWITH_TESTS=$(usex test)
+ -DTeXworks_PLUGIN_DIR="/usr/$(get_libdir)/texworks"
+ -DTeXworks_DOCS_DIR="/share/doc/${PF}"
+ -DQTPDF_VIEWER=ON
+ -DBUILD_SHARED_PLUGINS=ON
+ )
+
+ use lua && mycmakeargs+=( -DLUA_VERSION="$(lua_get_version)" )
+
+ cmake_src_configure
+}
+
+src_test() {
+ virtx cmake_src_test
+}