summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/broot/broot-1.44.6.ebuild')
-rw-r--r--app-misc/broot/broot-1.44.6.ebuild456
1 files changed, 456 insertions, 0 deletions
diff --git a/app-misc/broot/broot-1.44.6.ebuild b/app-misc/broot/broot-1.44.6.ebuild
new file mode 100644
index 000000000000..53c0fb42df45
--- /dev/null
+++ b/app-misc/broot/broot-1.44.6.ebuild
@@ -0,0 +1,456 @@
+# Copyright 2021-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+adler2@2.0.0
+ahash@0.8.11
+aho-corasick@1.1.3
+aligned-vec@0.5.0
+allocator-api2@0.2.21
+android-tzdata@0.1.1
+android_system_properties@0.1.5
+ansi_colours@1.2.3
+anstream@0.6.18
+anstyle@1.0.10
+anstyle-parse@0.2.6
+anstyle-query@1.1.2
+anstyle-wincon@3.0.6
+anyhow@1.0.95
+arbitrary@1.4.1
+arg_enum_proc_macro@0.3.4
+argh@0.1.13
+argh_derive@0.1.13
+argh_shared@0.1.13
+arrayref@0.3.9
+arrayvec@0.7.6
+autocfg@1.4.0
+av1-grain@0.2.3
+avif-serialize@0.8.2
+base64@0.13.1
+base64@0.21.7
+base64@0.22.1
+bet@1.0.4
+bincode@1.3.3
+bit-set@0.5.3
+bit-vec@0.6.3
+bit_field@0.10.2
+bitflags@1.3.2
+bitflags@2.7.0
+bitstream-io@2.6.0
+block2@0.5.1
+bstr@1.11.3
+built@0.7.5
+bumpalo@3.16.0
+bytemuck@1.21.0
+byteorder@1.5.0
+byteorder-lite@0.1.0
+cc@1.2.9
+cfg-expr@0.15.8
+cfg-if@1.0.0
+cfg_aliases@0.2.1
+char_reader@0.1.1
+chrono@0.4.39
+clap@4.5.26
+clap-help@1.3.1
+clap_builder@4.5.26
+clap_complete@4.5.42
+clap_derive@4.5.24
+clap_lex@0.7.4
+clap_mangen@0.2.26
+cli-log@2.1.0
+clipboard-win@4.5.0
+clipboard_macos@0.1.1
+color_quant@1.1.0
+colorchoice@1.0.3
+coolor@1.0.0
+core-foundation-sys@0.8.7
+crc32fast@1.4.2
+crokey@1.1.0
+crokey-proc_macros@1.1.0
+crossbeam@0.8.4
+crossbeam-channel@0.5.14
+crossbeam-deque@0.8.6
+crossbeam-epoch@0.9.18
+crossbeam-queue@0.3.12
+crossbeam-utils@0.8.21
+crossterm@0.28.1
+crossterm_winapi@0.9.1
+crunchy@0.2.2
+csv@1.3.1
+csv-core@0.1.11
+csv2svg@0.2.3
+custom_error@1.9.2
+data-url@0.3.1
+deranged@0.3.11
+deser-hjson@2.2.4
+directories@4.0.1
+directories@5.0.1
+dirs-sys@0.3.7
+dirs-sys@0.4.1
+displaydoc@0.2.5
+doc-comment@0.3.3
+either@1.13.0
+equivalent@1.0.1
+errno@0.3.10
+error-code@2.3.1
+exr@1.73.0
+fallible-iterator@0.3.0
+fallible-streaming-iterator@0.1.9
+fancy-regex@0.11.0
+fastrand@2.3.0
+fdeflate@0.3.7
+file-size@1.0.3
+flate2@1.0.35
+flex-grow@0.1.0
+float-cmp@0.9.0
+fnv@1.0.7
+foldhash@0.1.4
+fontconfig-parser@0.5.7
+fontdb@0.15.0
+form_urlencoded@1.2.1
+gethostname@0.3.0
+getrandom@0.2.15
+gif@0.12.0
+gif@0.13.1
+git2@0.20.0
+glassbench@0.4.4
+glob@0.3.2
+half@2.4.1
+hashbrown@0.14.5
+hashbrown@0.15.2
+hashlink@0.9.1
+heck@0.4.1
+heck@0.5.0
+home@0.5.11
+iana-time-zone@0.1.61
+iana-time-zone-haiku@0.1.2
+icu_collections@1.5.0
+icu_locid@1.5.0
+icu_locid_transform@1.5.0
+icu_locid_transform_data@1.5.0
+icu_normalizer@1.5.0
+icu_normalizer_data@1.5.0
+icu_properties@1.5.1
+icu_properties_data@1.5.0
+icu_provider@1.5.0
+icu_provider_macros@1.5.0
+id-arena@2.2.1
+idna@1.0.3
+idna_adapter@1.2.0
+image@0.25.5
+image-webp@0.2.1
+imagesize@0.12.0
+imgref@1.11.0
+include_dir@0.7.4
+include_dir_macros@0.7.4
+indexmap@2.7.0
+interpolate_name@0.2.4
+is_executable@1.0.4
+is_terminal_polyfill@1.70.1
+itertools@0.12.1
+itoa@1.0.14
+jobserver@0.1.32
+jpeg-decoder@0.3.1
+js-sys@0.3.76
+kurbo@0.9.5
+lazy-regex@3.4.1
+lazy-regex-proc_macros@3.4.1
+lazy_static@1.5.0
+lebe@0.5.2
+lfs-core@0.11.2
+libc@0.2.169
+libfuzzer-sys@0.4.8
+libgit2-sys@0.18.0+1.9.0
+libredox@0.1.3
+libsqlite3-sys@0.30.1
+libz-sys@1.1.21
+linked-hash-map@0.5.6
+linux-raw-sys@0.4.15
+litemap@0.7.4
+lock_api@0.4.12
+log@0.4.22
+loop9@0.1.5
+lru@0.12.5
+malloc_buf@0.0.6
+maybe-rayon@0.1.1
+memchr@2.7.4
+memmap2@0.8.0
+memmap2@0.9.5
+memoffset@0.7.1
+minimad@0.13.1
+minimal-lexical@0.2.1
+miniz_oxide@0.8.2
+mio@1.0.3
+new_debug_unreachable@1.0.6
+nix@0.26.4
+nix@0.29.0
+nom@7.1.3
+noop_proc_macro@0.3.0
+normpath@1.3.0
+num-bigint@0.4.6
+num-conv@0.1.0
+num-derive@0.4.2
+num-integer@0.1.46
+num-rational@0.4.2
+num-traits@0.2.19
+objc@0.2.7
+objc-sys@0.3.5
+objc2@0.5.2
+objc2-app-kit@0.2.2
+objc2-core-data@0.2.2
+objc2-core-image@0.2.2
+objc2-encode@4.0.3
+objc2-foundation@0.2.2
+objc2-metal@0.2.2
+objc2-quartz-core@0.2.2
+once_cell@1.20.2
+open@1.7.1
+opener@0.6.1
+option-ext@0.2.0
+parking_lot@0.12.3
+parking_lot_core@0.9.10
+paste@1.0.15
+pathdiff@0.2.3
+percent-encoding@2.3.1
+phf@0.11.3
+phf_generator@0.11.3
+phf_macros@0.11.3
+phf_shared@0.11.3
+pico-args@0.5.0
+pkg-config@0.3.31
+plist@1.7.0
+png@0.17.16
+powerfmt@0.2.0
+ppv-lite86@0.2.20
+proc-macro2@1.0.93
+proc-status@0.1.1
+profiling@1.0.16
+profiling-procmacros@1.0.16
+qoi@0.4.1
+quick-error@2.0.1
+quick-xml@0.32.0
+quote@1.0.38
+rand@0.8.5
+rand_chacha@0.3.1
+rand_core@0.6.4
+rav1e@0.7.1
+ravif@0.11.11
+rayon@1.10.0
+rayon-core@1.12.1
+rctree@0.5.0
+redox_syscall@0.5.8
+redox_users@0.4.6
+regex@1.11.1
+regex-automata@0.4.9
+regex-syntax@0.8.5
+resvg@0.36.0
+rgb@0.8.50
+roff@0.2.2
+roxmltree@0.18.1
+roxmltree@0.20.0
+rusqlite@0.32.1
+rust-fuzzy-search@0.1.1
+rustc-hash@2.1.0
+rustix@0.38.43
+rustybuzz@0.10.0
+ryu@1.0.18
+same-file@1.0.6
+scopeguard@1.2.0
+secular@1.0.1
+serde@1.0.217
+serde_derive@1.0.217
+serde_json@1.0.135
+serde_spanned@0.6.8
+shlex@1.3.0
+signal-hook@0.3.17
+signal-hook-mio@0.2.4
+signal-hook-registry@1.4.2
+simd-adler32@0.3.7
+simd_helpers@0.1.0
+simplecss@0.2.2
+siphasher@0.3.11
+siphasher@1.0.1
+slotmap@1.0.7
+smallvec@1.13.2
+snafu@0.7.5
+snafu-derive@0.7.5
+splitty@1.0.2
+stable_deref_trait@1.2.0
+str-buf@1.0.6
+strict@0.1.4
+strict@0.2.0
+strict-num@0.1.1
+strsim@0.11.1
+svg@0.16.0
+svgtypes@0.12.0
+syn@1.0.109
+syn@2.0.96
+synstructure@0.13.1
+syntect-no-panic@6.0.0
+system-deps@6.2.2
+target-lexicon@0.12.16
+tempfile@3.15.0
+termimad@0.31.1
+terminal-clipboard@0.4.1
+terminal-light@1.7.0
+termux-clipboard@0.1.0
+thiserror@1.0.69
+thiserror-impl@1.0.69
+tiff@0.9.1
+time@0.3.37
+time-core@0.1.2
+time-macros@0.2.19
+tiny-skia@0.11.4
+tiny-skia-path@0.11.4
+tinystr@0.7.6
+tinyvec@1.8.1
+tinyvec_macros@0.1.1
+toml@0.8.19
+toml_datetime@0.6.8
+toml_edit@0.22.22
+trash@3.3.1
+ttf-parser@0.19.2
+umask@2.1.0
+unicode-bidi@0.3.18
+unicode-bidi-mirroring@0.1.0
+unicode-ccc@0.1.2
+unicode-ident@1.0.14
+unicode-normalization@0.1.24
+unicode-properties@0.1.3
+unicode-script@0.5.7
+unicode-vo@0.1.0
+unicode-width@0.1.14
+url@2.5.4
+usvg@0.36.0
+usvg-parser@0.36.0
+usvg-text-layout@0.36.0
+usvg-tree@0.36.0
+utf16_iter@1.0.5
+utf8_iter@1.0.4
+utf8parse@0.2.2
+uzers@0.12.1
+v_frame@0.3.8
+vcpkg@0.2.15
+version-compare@0.2.0
+version_check@0.9.5
+walkdir@2.5.0
+wasi@0.11.0+wasi-snapshot-preview1
+wasm-bindgen@0.2.99
+wasm-bindgen-backend@0.2.99
+wasm-bindgen-macro@0.2.99
+wasm-bindgen-macro-support@0.2.99
+wasm-bindgen-shared@0.2.99
+weezl@0.1.8
+which@4.4.2
+winapi@0.3.9
+winapi-i686-pc-windows-gnu@0.4.0
+winapi-util@0.1.9
+winapi-wsapoll@0.1.2
+winapi-x86_64-pc-windows-gnu@0.4.0
+windows@0.44.0
+windows-core@0.52.0
+windows-sys@0.48.0
+windows-sys@0.52.0
+windows-sys@0.59.0
+windows-targets@0.42.2
+windows-targets@0.48.5
+windows-targets@0.52.6
+windows_aarch64_gnullvm@0.42.2
+windows_aarch64_gnullvm@0.48.5
+windows_aarch64_gnullvm@0.52.6
+windows_aarch64_msvc@0.42.2
+windows_aarch64_msvc@0.48.5
+windows_aarch64_msvc@0.52.6
+windows_i686_gnu@0.42.2
+windows_i686_gnu@0.48.5
+windows_i686_gnu@0.52.6
+windows_i686_gnullvm@0.52.6
+windows_i686_msvc@0.42.2
+windows_i686_msvc@0.48.5
+windows_i686_msvc@0.52.6
+windows_x86_64_gnu@0.42.2
+windows_x86_64_gnu@0.48.5
+windows_x86_64_gnu@0.52.6
+windows_x86_64_gnullvm@0.42.2
+windows_x86_64_gnullvm@0.48.5
+windows_x86_64_gnullvm@0.52.6
+windows_x86_64_msvc@0.42.2
+windows_x86_64_msvc@0.48.5
+windows_x86_64_msvc@0.52.6
+winnow@0.6.24
+write16@1.0.0
+writeable@0.5.5
+x11-clipboard@0.8.1
+x11rb@0.12.0
+x11rb-protocol@0.12.0
+xmlparser@0.13.6
+xmlwriter@0.1.0
+xterm-query@0.5.0
+yaml-rust@0.4.5
+yoke@0.7.5
+yoke-derive@0.7.5
+zerocopy@0.7.35
+zerocopy-derive@0.7.35
+zerofrom@0.1.5
+zerofrom-derive@0.1.5
+zerovec@0.10.4
+zerovec-derive@0.10.3
+zune-core@0.4.12
+zune-inflate@0.2.54
+zune-jpeg@0.4.14
+"
+
+RUST_MIN_VER="1.79.0"
+inherit cargo shell-completion
+
+DESCRIPTION="A new way to see and navigate directory trees"
+HOMEPAGE="https://dystroy.org/broot/ https://github.com/Canop/broot"
+SRC_URI="https://github.com/Canop/broot/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ ${CARGO_CRATE_URIS}"
+
+LICENSE="Apache-2.0 BSD-2 BSD LGPL-3+ MIT ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="X"
+
+RDEPEND="
+ dev-libs/libgit2:=
+ sys-libs/zlib
+ X? ( x11-libs/libxcb:= )
+"
+DEPEND="${RDEPEND}"
+
+QA_FLAGS_IGNORED="usr/bin/${PN}"
+
+src_prepare() {
+ default
+
+ local mandate=$(date -r man/page +'%Y/%m/%d' || die)
+ sed -e "s|#version|${PV}|" \
+ -e "s|#date|${mandate}|" \
+ man/page > "${T}"/${PN}.1 || die
+}
+
+src_configure() {
+ export RUSTFLAGS="-Cstrip=none ${RUSTFLAGS}" #835400
+ local myfeatures=( $(usev X clipboard) trash )
+
+ cargo_src_configure --no-default-features
+}
+
+src_install() {
+ cargo_src_install
+
+ doman "${T}"/${PN}.1
+
+ local build_dir=( "$(cargo_target_dir)"/build/${PN}-*/out )
+ cd ${build_dir[0]} || die
+
+ newbashcomp ${PN}.bash ${PN}
+ newbashcomp br.bash br
+
+ dozshcomp _${PN} _br
+ dofishcomp ${PN}.fish br.fish
+}