summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/glabels')
-rw-r--r--app-office/glabels/files/glabels-externs.patch24
-rw-r--r--app-office/glabels/glabels-3.4.1.ebuild4
2 files changed, 28 insertions, 0 deletions
diff --git a/app-office/glabels/files/glabels-externs.patch b/app-office/glabels/files/glabels-externs.patch
new file mode 100644
index 000000000000..5722912154bb
--- /dev/null
+++ b/app-office/glabels/files/glabels-externs.patch
@@ -0,0 +1,24 @@
+diff -up glabels-3.4.1/src/font-history.h.f32 glabels-3.4.1/src/font-history.h
+--- glabels-3.4.1/src/font-history.h.f32 2016-03-04 05:01:15.000000000 +0100
++++ glabels-3.4.1/src/font-history.h 2020-02-03 08:41:46.371176433 +0100
+@@ -28,7 +28,7 @@
+ G_BEGIN_DECLS
+
+
+-glFontHistoryModel *gl_font_history;
++extern glFontHistoryModel *gl_font_history;
+
+
+ void gl_font_history_init (void);
+diff -up glabels-3.4.1/src/template-history.h.f32 glabels-3.4.1/src/template-history.h
+--- glabels-3.4.1/src/template-history.h.f32 2016-03-04 05:01:15.000000000 +0100
++++ glabels-3.4.1/src/template-history.h 2020-02-03 08:42:28.547175850 +0100
+@@ -28,7 +28,7 @@
+ G_BEGIN_DECLS
+
+
+-glTemplateHistoryModel *gl_template_history;
++extern glTemplateHistoryModel *gl_template_history;
+
+
+ void gl_template_history_init (void);
diff --git a/app-office/glabels/glabels-3.4.1.ebuild b/app-office/glabels/glabels-3.4.1.ebuild
index 23065b3be108..2f70ff77c791 100644
--- a/app-office/glabels/glabels-3.4.1.ebuild
+++ b/app-office/glabels/glabels-3.4.1.ebuild
@@ -32,6 +32,10 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/glabels-externs.patch # Fix compilation with -fno-common/gcc10; patch from Fedora
+)
+
src_configure() {
gnome2_src_configure \
$(use_with eds libebook) \