summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/tree/files/tree-2.81-gcc11.patch33
-rw-r--r--dev-cpp/tree/files/tree-2.81-test.patch36
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-cpp/tree/files/tree-2.81-gcc11.patch b/dev-cpp/tree/files/tree-2.81-gcc11.patch
deleted file mode 100644
index feffe0de13cc..000000000000
--- a/dev-cpp/tree/files/tree-2.81-gcc11.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- "a/simple tree.hpp"
-+++ "b/simple tree.hpp"
-@@ -323,7 +323,7 @@
- public:
- compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
-
-- bool operator()(const tree_node *a, const tree_node *b)
-+ bool operator()(const tree_node *a, const tree_node *b) const
- {
- return comp_(a->data, b->data);
- }
---- a/tree.hh
-+++ b/tree.hh
-@@ -422,7 +422,7 @@
- public:
- compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
-
-- bool operator()(const tree_node *a, const tree_node *b)
-+ bool operator()(const tree_node *a, const tree_node *b) const
- {
- return comp_(a->data, b->data);
- }
---- a/xinlin.hh
-+++ b/xinlin.hh
-@@ -332,7 +332,7 @@
- public:
- compare_nodes(StrictWeakOrdering comp) : comp_(comp) {};
-
-- bool operator()(const tree_node *a, const tree_node *b)
-+ bool operator()(const tree_node *a, const tree_node *b) const
- {
- return comp_(a->data, b->data);
- }
diff --git a/dev-cpp/tree/files/tree-2.81-test.patch b/dev-cpp/tree/files/tree-2.81-test.patch
deleted file mode 100644
index c9e675dc7953..000000000000
--- a/dev-cpp/tree/files/tree-2.81-test.patch
+++ /dev/null
@@ -1,36 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -1,13 +1,6 @@
--
--%.o: %.cc
-- g++ -c -I. $^
--
--test1: test1.o
-- g++ -o test1 test1.o
--
--run_tests: test1 test1.req
-- ./test1 > test1.res
-- @diff test1.res test1.req
-+check: test_tree
-+ ./test_tree > mytest.output && \
-+ diff -Nu test_tree.output mytest.output
- @echo "*** All tests OK ***"
-
- clean:
---- a/test_tree.output
-+++ b/test_tree.output
-@@ -1,3 +1,8 @@
-+-----
-+hi
-+ 1
-+ 0
-+-----
- empty tree to begin with:
- 0
- 'more text' is sibling 2 in its sibling range
-@@ -309,3 +314,5 @@
- D
- I
- -----
-+G
-+H