summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.9.5.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.5.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.5.ebuild
index ba865aa3d9e4..7ad641757006 100644
--- a/dev-libs/jsoncpp/jsoncpp-1.9.5.ebuild
+++ b/dev-libs/jsoncpp/jsoncpp-1.9.5.ebuild
@@ -3,14 +3,16 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
+
inherit meson python-any-r1
DESCRIPTION="C++ JSON reader and writer"
-HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp/"
SRC_URI="
https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz
- -> ${P}.tar.gz"
+ -> ${P}.tar.gz
+"
LICENSE="|| ( public-domain MIT )"
SLOT="0/25"
@@ -20,8 +22,8 @@ RESTRICT="!test? ( test )"
BDEPEND="
${PYTHON_DEPS}
- doc? ( app-doc/doxygen )"
-RDEPEND=""
+ doc? ( app-doc/doxygen )
+"
src_configure() {
local emesonargs=(