summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/httpx-socks')
-rw-r--r--dev-python/httpx-socks/Manifest1
-rw-r--r--dev-python/httpx-socks/httpx-socks-0.7.6.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/httpx-socks/Manifest b/dev-python/httpx-socks/Manifest
index 5846d3d30a62..50cad1500761 100644
--- a/dev-python/httpx-socks/Manifest
+++ b/dev-python/httpx-socks/Manifest
@@ -1 +1,2 @@
DIST httpx-socks-0.7.5.gh.tar.gz 24847 BLAKE2B 9c119b756bf493df47a1bc9c36339508a2192d2bd4392113955fed6929d7c79654f17c069f9d952a11d8c95cf210cdf54af1bb59f47dc50b26b180f0915d3fe9 SHA512 df921af0c5fd0e8b4cb127cd13d5285ae57eb6ff9bc95f9422c02c79771ef55f345ef1618156fd0887467ed81cad2081ea9f2a56a03dc1d80948ed9eabe67aee
+DIST httpx-socks-0.7.6.gh.tar.gz 15116 BLAKE2B d94e13cf61a831cc36486962dd493ebfff4822a73c39f9be30fb2c13720330ec6e6ec1fb763ef1551f00fd97270a8b288e4ed7fc2b30c2f78cd8f608e88d77a6 SHA512 08e2d72d93896c15cc9e455f5d878d1015b72da48b17e53a361f7af2d0890caca42478a0f295332093afa19735a0a2fd4fddf13d09c7baf57575cd6534f9cdf9
diff --git a/dev-python/httpx-socks/httpx-socks-0.7.6.ebuild b/dev-python/httpx-socks/httpx-socks-0.7.6.ebuild
new file mode 100644
index 000000000000..79e93a2e4311
--- /dev/null
+++ b/dev-python/httpx-socks/httpx-socks-0.7.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Proxy (HTTP, SOCKS) transports for httpx"
+HOMEPAGE="
+ https://github.com/romis2012/httpx-socks/
+ https://pypi.org/project/httpx-socks/
+"
+# no tests in sdist, as of 0.7.6
+SRC_URI="
+ https://github.com/romis2012/httpx-socks/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ <dev-python/httpx-0.25.0[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.21.0[${PYTHON_USEDEP}]
+ <dev-python/httpcore-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/httpcore-0.14.0[${PYTHON_USEDEP}]
+ >=dev-python/python-socks-2.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ >=dev-python/hypercorn-0.12.0[${PYTHON_USEDEP}]
+ >=dev-python/pytest-asyncio-0.18.3[${PYTHON_USEDEP}]
+ >=dev-python/pytest-trio-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/starlette-0.19.1[${PYTHON_USEDEP}]
+ >=dev-python/trio-0.18.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.6.3[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest