summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/path-py')
-rw-r--r--dev-python/path-py/Manifest1
-rw-r--r--dev-python/path-py/path-py-15.1.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/path-py/Manifest b/dev-python/path-py/Manifest
index ae0f57471f31..968329dc7206 100644
--- a/dev-python/path-py/Manifest
+++ b/dev-python/path-py/Manifest
@@ -1,3 +1,4 @@
DIST path-15.0.0.tar.gz 73642 BLAKE2B 186b77b6571dd878a5b64b575289bb5ee549145ccd0c7b858f99c9e3772cf98f2cc7ff5da759e7fa660296abc49c053a388ad95466c51adccce2162c682c6566 SHA512 e41684c576b959e27258f60c0d8b69719c38a5a7a04d9646089aea91227781573368a08f01230dca831732ae687741d22caf52efd9a481378b8d4e77627fe3a5
DIST path-15.0.1.tar.gz 47662 BLAKE2B ec50e75cd1b24cd017189cb8632340a5e4ebed8517d607a9f26e43c7c75b2b7d62e9a70b6b93ea6db79feb3d100ca535aba7926cfd7317bef1ac290697ea8f90 SHA512 d8ea2a98cf5caad15bc99a740188d6947cb1cdacc1ac7b6164f29f8d78ca8e73258120ff36f100957e3c4c2ca0ed6eaf27c98c4765ededde41b58d98de24f672
DIST path-15.1.0.tar.gz 48271 BLAKE2B 3f71d7686bae65f0b605d8fb2077395e5f5f36ec6f29c41f18e2380c6f775e5bd5bc8c2d3589fe507ad49c7383f1cab84b59176e1d5952d02cec68037bf3e4b0 SHA512 31c40fc57d6c6c57fece4fec720b344191cc3d395efe9e5f071c98a7392727535150c6952a4f8174b037141d5cb1b026c2fa44da8921a8354ee1627daf8f6977
+DIST path-15.1.2.tar.gz 48280 BLAKE2B 6dd6be743939d4ac1edd5caab18658473d7318eaf255140198db34cfb28c95322ed8ae05284683b18a0146f412ff8a2c14dae60d018740f8bb9cfda861b8ea20 SHA512 76f2a04800154ee8c7b7b9783bf7c63c544da74bb2f92424aeb437448a04dcdec008deab262d3b40d515404e6144bbad44e618d824974654ef10676878415ba4
diff --git a/dev-python/path-py/path-py-15.1.2.ebuild b/dev-python/path-py/path-py-15.1.2.ebuild
new file mode 100644
index 000000000000..ec0d713f9c9a
--- /dev/null
+++ b/dev-python/path-py/path-py-15.1.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} pypy3 )
+inherit distutils-r1
+
+MY_P="path-${PV}"
+DESCRIPTION="A module wrapper for os.path"
+HOMEPAGE="https://pypi.org/project/path/ https://github.com/jaraco/path"
+SRC_URI="mirror://pypi/p/path/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ !<dev-python/pytest-shutil-1.7.0-r1
+ !<dev-python/pytest-virtualenv-1.7.0-r1"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local deselect=(
+ # unreliable, not really meaningful for end users
+ test_path.py::TestPerformance
+ )
+
+ PYTHONPATH=. pytest -vv ${deselect[@]/#/--deselect } || die
+}