summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/localhost')
-rw-r--r--dev-ruby/localhost/Manifest1
-rw-r--r--dev-ruby/localhost/localhost-1.1.10.ebuild39
2 files changed, 0 insertions, 40 deletions
diff --git a/dev-ruby/localhost/Manifest b/dev-ruby/localhost/Manifest
index 36e4e02455c0..f0e74a93962c 100644
--- a/dev-ruby/localhost/Manifest
+++ b/dev-ruby/localhost/Manifest
@@ -1,2 +1 @@
-DIST localhost-1.1.10.tar.gz 2128142 BLAKE2B 06e4ab07bc273b8beba5fb3ee3f64e171a6c4a2e944c6d5e432417560283230277213732bf23ddd12e9737b2803582a11fdaa76356d14d2bdbd4e90d402c6204 SHA512 946ef247b256165cf5c849a32c0ba8dd2007164bd1549a20aca595328174709e9213ba8a98448dc41a57558b00147c3b7428b7bc625059ab24f89c94ff8850e9
DIST localhost-1.3.0.tar.gz 2128850 BLAKE2B fe7db9958759be39107116b45ee1f8d3678a2407f25956ee551a41a18da2bb12b46add992ca2b9615b68f69156afc384c453318af5b77751095b643fb27b7344 SHA512 6196cf4ff79cd53c222e19158a7233b8ba384225f24fd791d92952c80b11c469e99d619c3825e0f831e99e2a822aaf69e3b3a9ed0dc2e1ad0316c8b6717165c5
diff --git a/dev-ruby/localhost/localhost-1.1.10.ebuild b/dev-ruby/localhost/localhost-1.1.10.ebuild
deleted file mode 100644
index 29a9d0c56b27..000000000000
--- a/dev-ruby/localhost/localhost-1.1.10.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="readme.md"
-RUBY_FAKEGEM_GEMSPEC="localhost.gemspec"
-RUBY_FAKEGEM_RECIPE_TEST="sus"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Manage a local CA for self-signed localhost development servers"
-HOMEPAGE="https://github.com/socketry/localhost"
-SRC_URI="https://github.com/socketry/localhost/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc x86"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/async-io
- dev-ruby/async-process
- dev-ruby/sus-fixtures-async
- )
-"
-
-all_ruby_prepare() {
- sed -i -e 's:_relative ": "./:' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/covered/Id' config/sus.rb || die
-}
-
-each_ruby_test() {
- # Tests fail in parallel as it tries to use the same port so
- # manually replicate ruby-ng_sus for now, as ruby-ng_sus runs sus-parallel.
- ${RUBY} -S sus || die
-}