summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgconfig')
-rw-r--r--dev-util/pkgconfig/pkgconfig-9999.ebuild25
1 files changed, 22 insertions, 3 deletions
diff --git a/dev-util/pkgconfig/pkgconfig-9999.ebuild b/dev-util/pkgconfig/pkgconfig-9999.ebuild
index 90e416b25b2f..31f6de36737e 100644
--- a/dev-util/pkgconfig/pkgconfig-9999.ebuild
+++ b/dev-util/pkgconfig/pkgconfig-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
# Do not inherit autotools in non-live ebuild - causes circular dependency, bug #550856
inherit eutils flag-o-matic libtool multilib multilib-minimal
@@ -30,7 +30,8 @@ IUSE="elibc_FreeBSD elibc_glibc hardened internal-glib"
RDEPEND="!internal-glib? ( >=dev-libs/glib-2.34.3[${MULTILIB_USEDEP}] )
!dev-util/pkgconf[pkg-config]
!dev-util/pkg-config-lite
- !dev-util/pkgconfig-openbsd[pkg-config]"
+ !dev-util/pkgconfig-openbsd[pkg-config]
+ virtual/libintl"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
@@ -40,13 +41,21 @@ DOCS=( AUTHORS NEWS README )
src_prepare() {
sed -i -e "s|^prefix=/usr\$|prefix=${EPREFIX}/usr|" check/simple.pc || die #434320
- epatch_user
+ eapply_user
if [[ ${PV} == *9999* ]]; then
eautoreconf
else
elibtoolize # Required for FreeMiNT wrt #333429
fi
+
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # fix standards conflicts
+ sed -i -e 's/\(_XOPEN_SOURCE\(_EXTENDED\)\?\|__EXTENSIONS__\)/ \1_DISABLED/' \
+ glib/configure || die
+ sed -i -e '/#define\s\+_POSIX_SOURCE/d' \
+ glib/glib/giounix.c || die
+ fi
}
multilib_src_configure() {
@@ -62,6 +71,16 @@ multilib_src_configure() {
# add the libdir for libtool, otherwise it'll make love with system
# installed libiconv
append-ldflags "-L${EPREFIX}/usr/$(get_libdir)"
+ # the glib objects reference symbols from these frameworks,
+ # not good, esp. since Carbon should be deprecated
+ [[ ${CHOST} == *-darwin* ]] && \
+ append-ldflags -framework CoreFoundation -framework Carbon
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ # required due to __EXTENSIONS__
+ append-cppflags -DENABLE_NLS
+ # similar to Darwin
+ append-ldflags -lintl
+ fi
fi
else
if ! has_version dev-util/pkgconfig; then