summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libaccounts-glib/Manifest2
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.18.ebuild30
-rw-r--r--net-libs/libaccounts-glib/libaccounts-glib-1.21.ebuild45
3 files changed, 46 insertions, 31 deletions
diff --git a/net-libs/libaccounts-glib/Manifest b/net-libs/libaccounts-glib/Manifest
index 8b5f871f34c3..8a0bb1c2d5f0 100644
--- a/net-libs/libaccounts-glib/Manifest
+++ b/net-libs/libaccounts-glib/Manifest
@@ -1,2 +1,2 @@
-DIST libaccounts-glib-1.18.tar.gz 579435 SHA256 7aab9ec2ba3ae2548125f4bb330ed433e8066c672e32101a339cbb7f4657ff56 SHA512 133b336cd000f302f14d4285d5a3c6d032a2b5497bf8ce5cd22175e6c847b54e4f8919a6c37786c9b39bac874146683a1bc0547db3f2563e3fe7a3d686d82b85 WHIRLPOOL 102cdd1261bff9980c14f6563bcc41fc561b1751cc6adcc5ed7f6045800c8974443a99512f18352d2ebecd58ee9f69bebd30b52a8106fb15d59095705afaefe9
DIST libaccounts-glib-1.19.tar.gz 126032 SHA256 098362920817fb2e4429814b8a26451c00bddd5e4702ab584a37fda42a539e50 SHA512 1f0dfb3ee9faa32e08c839130bb2fb32d71ab57973d9a5704e145d192815795c3a8ddb4cc004e12647dffb02bd6e5f3ae908dfd7006e14f9b18e6454b5eb3d76 WHIRLPOOL 36e7a5b33dbc5ffdbffb0cdcfe21d07c624601002b3959d25698fcad786bc3b00ada074597042dbb45e95bc8b7518b66f24fefc8bbebf6b516ddc91c233ba4b2
+DIST libaccounts-glib-1.21.tar.gz 126032 SHA256 098362920817fb2e4429814b8a26451c00bddd5e4702ab584a37fda42a539e50 SHA512 1f0dfb3ee9faa32e08c839130bb2fb32d71ab57973d9a5704e145d192815795c3a8ddb4cc004e12647dffb02bd6e5f3ae908dfd7006e14f9b18e6454b5eb3d76 WHIRLPOOL 36e7a5b33dbc5ffdbffb0cdcfe21d07c624601002b3959d25698fcad786bc3b00ada074597042dbb45e95bc8b7518b66f24fefc8bbebf6b516ddc91c233ba4b2
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.18.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.18.ebuild
deleted file mode 100644
index b3373fd66f96..000000000000
--- a/net-libs/libaccounts-glib/libaccounts-glib-1.18.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
-HOMEPAGE="https://01.org/gsso/"
-SRC_URI="http://dev.gentoo.org/~kensington/distfiles/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~x86 ~amd64"
-IUSE="debug"
-
-RESTRICT="test"
-
-DEPEND="
- dev-db/sqlite:3
- dev-libs/glib:2
- dev-libs/libxml2"
-
-RDEPEND="$DEPEND"
-
-src_configure() {
- export HAVE_GCOV_FALSE='#'
- econf \
- $(use_enable debug) \
- --disable-tests
-}
diff --git a/net-libs/libaccounts-glib/libaccounts-glib-1.21.ebuild b/net-libs/libaccounts-glib/libaccounts-glib-1.21.ebuild
new file mode 100644
index 000000000000..339afc3432fc
--- /dev/null
+++ b/net-libs/libaccounts-glib/libaccounts-glib-1.21.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils vcs-snapshot
+
+DESCRIPTION="Accounts SSO (Single Sign-On) management library for GLib applications"
+HOMEPAGE="https://01.org/gsso/"
+SRC_URI="https://gitlab.com/accounts-sso/libaccounts-glib/repository/archive.tar.gz?ref=VERSION_1.19 -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libxml2
+"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+"
+
+RESTRICT="test"
+
+DOCS=( AUTHORS NEWS )
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-python \
+ --disable-tests \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}