summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/eventd')
-rw-r--r--net-misc/eventd/eventd-0.27.0-r1.ebuild3
-rw-r--r--net-misc/eventd/files/eventd-0.27.0-fno-common.patch11
2 files changed, 14 insertions, 0 deletions
diff --git a/net-misc/eventd/eventd-0.27.0-r1.ebuild b/net-misc/eventd/eventd-0.27.0-r1.ebuild
index b0d6a59a9665..5805963615d5 100644
--- a/net-misc/eventd/eventd-0.27.0-r1.ebuild
+++ b/net-misc/eventd/eventd-0.27.0-r1.ebuild
@@ -66,6 +66,9 @@ RDEPEND="${COMMON_DEPEND}
net-libs/glib-networking[ssl]
"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.27.0-fno-common.patch
+)
pkg_setup() {
if use ipv6; then
diff --git a/net-misc/eventd/files/eventd-0.27.0-fno-common.patch b/net-misc/eventd/files/eventd-0.27.0-fno-common.patch
new file mode 100644
index 000000000000..5f731666738c
--- /dev/null
+++ b/net-misc/eventd/files/eventd-0.27.0-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/plugins/nd/src/backend.h
++++ b/plugins/nd/src/backend.h
+@@ -37,7 +37,7 @@
+ _EVENTD_ND_BACKENDS_SIZE
+ } EventdNdBackends;
+
+-const gchar *eventd_nd_backends_names[_EVENTD_ND_BACKENDS_SIZE];
++extern const gchar *eventd_nd_backends_names[_EVENTD_ND_BACKENDS_SIZE];
+
+ typedef struct {
+ EventdNdContext *context;