summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/votca/votca-9999.ebuild')
-rw-r--r--sci-chemistry/votca/votca-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sci-chemistry/votca/votca-9999.ebuild b/sci-chemistry/votca/votca-9999.ebuild
index a60728a6a6a9..0962e065f91d 100644
--- a/sci-chemistry/votca/votca-9999.ebuild
+++ b/sci-chemistry/votca/votca-9999.ebuild
@@ -2,8 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+PYTHON_COMPAT=( python3_{8..10} )
-inherit bash-completion-r1 cmake
+inherit bash-completion-r1 cmake python-single-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,12 +26,14 @@ HOMEPAGE="https://www.votca.org/"
LICENSE="Apache-2.0"
SLOT="0"
IUSE="+gromacs test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RESTRICT="!test? ( test )"
RDEPEND="
!sci-libs/votca-tools
!sci-chemistry/votca-csg
!sci-chemistry/votca-xtp
+ ${PYTHON_DEPS}
app-shells/bash:*
>=dev-cpp/eigen-3.3
dev-libs/boost:=
@@ -47,6 +50,13 @@ BDEPEND="virtual/pkgconfig"
DOCS=( README.rst NOTICE.rst CHANGELOG.rst )
+src_prepare() {
+ # espressopp was removed from gentoo
+ rm -r ./csg-tutorials/spce/ibi_espressopp || die
+ python_fix_shebang .
+ cmake_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_TESTING=$(usex test)