summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild
index 9bbbd54dd2a9..490d6c2f740d 100644
--- a/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.5.3.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit eutils fdo-mime multilib toolchain-funcs
+inherit desktop toolchain-funcs xdg-utils
DESCRIPTION="PC/SC Architecture smartcard tools"
HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/"
@@ -24,11 +24,6 @@ DOCS=(
README Changelog
)
-src_prepare() {
- default
- sed -i -e 's:-Wall -O2:$(CFLAGS):g' Makefile
-}
-
src_compile() {
# explicitly only build the pcsc_scan application, or the man
# pages will be gzipped first, and then unpacked.
@@ -59,9 +54,9 @@ src_install() {
}
pkg_postinst() {
- use gtk && fdo-mime_desktop_database_update
+ use gtk && xdg_desktop_database_update
}
pkg_postrm() {
- fdo-mime_desktop_database_update
+ xdg_desktop_database_update
}