From 485de1672254ab88537c6d1964bd8f0e3b99eb3f Mon Sep 17 00:00:00 2001
From: Alexis Ballier <aballier@gentoo.org>
Date: Wed, 20 Jan 2021 21:22:50 +0100
Subject: dev-ros/ament_cmake_python: bump to 1.0.3

Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
---
 .../ament_cmake_python-1.0.3.ebuild                | 47 ++++++++++++++++++++++
 1 file changed, 47 insertions(+)
 create mode 100644 dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild

(limited to 'dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild')

diff --git a/dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild b/dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild
new file mode 100644
index 000000000000..7f0a525558f8
--- /dev/null
+++ b/dev-ros/ament_cmake_python/ament_cmake_python-1.0.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit cmake python-any-r1
+
+ROS_PN="ament_cmake"
+if [ "${PV#9999}" != "${PV}" ] ; then
+	inherit git-r3
+	EGIT_REPO_URI="https://github.com/ament/ament_cmake"
+	SRC_URI=""
+	S=${WORKDIR}/${P}/${PN}
+else
+	SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+	S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="The ability to use Python in the ament buildsystem"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+	KEYWORDS=""
+else
+	KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND="
+	dev-ros/ament_cmake_core
+"
+DEPEND="${RDEPEND}"
+# Deps here are transitive from ament_cmake_core to have matching python support
+BDEPEND="
+	$(python_gen_any_dep 'dev-python/ament_package[${PYTHON_USEDEP}] dev-python/catkin_pkg[${PYTHON_USEDEP}]')
+	${PYTHON_DEPS}
+"
+PATCHES=( "${FILESDIR}/destdir.patch" )
+
+python_check_deps() {
+	has_version "dev-python/ament_package[${PYTHON_USEDEP}]" && \
+		has_version "dev-python/catkin_pkg[${PYTHON_USEDEP}]"
+}
-- 
cgit v1.2.3-65-gdbad