From 92000a4a8bf0ba9e9e10ffc1637dbefb40ceef64 Mon Sep 17 00:00:00 2001
From: Matthew Thode <prometheanfire@gentoo.org>
Date: Tue, 23 Feb 2016 13:58:11 -0600
Subject: net-analyzer/icinga2: bup

Package-Manager: portage-2.2.26
---
 net-analyzer/icinga2/Manifest             |   1 +
 net-analyzer/icinga2/icinga2-2.4.2.ebuild | 162 ++++++++++++++++++++++++++++++
 2 files changed, 163 insertions(+)
 create mode 100644 net-analyzer/icinga2/icinga2-2.4.2.ebuild

(limited to 'net-analyzer/icinga2')

diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index ca4447807f1c..894685f64c4d 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,2 +1,3 @@
 DIST icinga2-2.3.11.tar.gz 843985 SHA256 b499c46b9371e0046030226f61b9b056bc16e37138f318c88cd9dd2b4edf3152 SHA512 2011b4a8f6aaab90957427dc90c5de49ae7be97ade9f487882c955807e19455a59dc54869c1ca6a0538c6f1e793fc30815438514d78591338af579a50d022dd8 WHIRLPOOL 69622d7848f16c29fb9bba55e8cad09d1d9cb967d4b70941e7df7379d32e85c392be843703255eac884a659fbc46a263ee4e5d6a27659055d72b628d89478277
 DIST icinga2-2.4.1.tar.gz 1342073 SHA256 0cd3f52ec283fbad1e68fe9c6cf91e870e0161336f1108c2d7ea044c4db934f0 SHA512 53d93d7db090d478d93a4142e495438306582a5bd75fb69242053ba1213cbfefb4bfba560392cccb532623b3885cc1357b0ffdd9259215c34d681dcd072b52f0 WHIRLPOOL 57cbac7586f309373ed1662b3a12398d71318239f4dc70252905c8b770e240425832e9f38414d0a952ae9039db29474643f4d0b50d24e5a97c1af906b896dd20
+DIST icinga2-2.4.2.tar.gz 1359694 SHA256 3f51f4aff2bc78d59051c442a5ab984a038e4396cf9f3835b91bd5eb327d353c SHA512 1be13d3e8492ba802e6b5b0e9ed1a54d9a722a35585df1f601761c5f1f33b2b4ac17d6b82ca8a34955b065d84f9b2d57e259809548958096ae1d6178c1903bf5 WHIRLPOOL 58a898f639073a2d20af062f338ce222ee94d247cac71abbfdc5191ae737c30764f9a064958c5ce044eb9829021e1513d9cd74548392d92a914f2c631a8b6932
diff --git a/net-analyzer/icinga2/icinga2-2.4.2.ebuild b/net-analyzer/icinga2/icinga2-2.4.2.ebuild
new file mode 100644
index 000000000000..3902285bdaae
--- /dev/null
+++ b/net-analyzer/icinga2/icinga2-2.4.2.ebuild
@@ -0,0 +1,162 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils depend.apache eutils systemd toolchain-funcs user
+
+DESCRIPTION="Distributed, general purpose, network monitoring engine"
+HOMEPAGE="http://icinga.org/icinga2"
+SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres classicui console lto mail minimal nano-syntax +plugins studio +vim-syntax"
+
+CDEPEND="
+	dev-libs/openssl:0
+	>=dev-libs/boost-1.41
+	console? ( dev-libs/libedit )
+	mysql? ( virtual/mysql )
+	postgres? ( dev-db/postgresql:= )"
+
+DEPEND="
+	${CDEPEND}
+	sys-devel/bison
+	>=sys-devel/flex-2.5.35"
+
+RDEPEND="
+	${CDEPEND}
+	plugins? ( || (
+		net-analyzer/monitoring-plugins
+		net-analyzer/nagios-plugins
+	) )
+	mail? ( virtual/mailx )
+	classicui? ( net-analyzer/icinga[web] )
+	studio? ( x11-libs/wxGTK:2.9 )"
+
+REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
+
+want_apache2
+
+pkg_setup() {
+	depend.apache_pkg_setup
+	enewgroup icinga
+	enewgroup icingacmd
+	enewgroup nagios  # for plugins
+	enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
+}
+
+src_configure() {
+	sed -i 's/FLAGS\}\ \-g/FLAGS\}\ \-lpthread\ /g' CMakeLists.txt || die
+	local mycmakeargs=(
+		-DICINGA2_UNITY_BUILD=FALSE
+		-DCMAKE_VERBOSE_MAKEFILE=ON
+		-DCMAKE_BUILD_TYPE=None
+		-DCMAKE_INSTALL_PREFIX=/usr
+		-DCMAKE_INSTALL_SYSCONFDIR=/etc
+		-DCMAKE_INSTALL_LOCALSTATEDIR=/var
+		-DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+		-DICINGA2_USER=icinga
+		-DICINGA2_GROUP=icingacmd
+		-DICINGA2_COMMAND_USER=icinga
+		-DICINGA2_COMMAND_GROUP=icingacmd
+		-DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+	)
+	# default to off if minimal, allow the flags to be set otherwise
+	if use minimal; then
+		mycmakeargs+=(
+			-DICINGA2_WITH_MYSQL=OFF
+			-DICINGA2_WITH_PGSQL=OFF
+		)
+	else
+		mycmakeargs+=(
+			-DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
+			-DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
+		)
+	fi
+	# LTO
+	if use lto; then
+		mycmakeargs+=(
+			-DICINGA2_LTO_BUILD=ON
+		)
+	else
+		mycmakeargs+=(
+			-DICINGA2_LTO_BUILD=OFF
+		)
+	fi
+	# STUDIO
+	if use studio; then
+		mycmakeargs+=(
+			-DICINGA2_WITH_STUDIO=ON
+		)
+	else
+		mycmakeargs+=(
+			-DICINGA2_WITH_STUDIO=OFF
+		)
+	fi
+
+	cmake-utils_src_configure
+}
+
+src_install() {
+	BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
+	cd "${BUILDDIR}" || die
+
+	emake DESTDIR="${D}" install
+
+	einstalldocs
+
+	newinitd "${FILESDIR}"/icinga2.initd icinga2
+	newconfd "${FILESDIR}"/icinga2.confd icinga2
+
+	if use mysql ; then
+		docinto schema
+		newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
+		docinto schema/upgrade
+		dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
+	elif use postgres ; then
+		docinto schema
+		newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
+		docinto schema/upgrade
+		dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
+	fi
+
+	keepdir /etc/icinga2
+	keepdir /var/lib/icinga2/api/zones
+	keepdir /var/lib/icinga2/api/repository
+	keepdir /var/lib/icinga2/api/log
+	keepdir /var/spool/icinga2/perfdata
+
+	rm -r "${D}/var/run" || die "failed to remove /var/run"
+	rm -r "${D}/var/cache" || die "failed to remove /var/cache"
+
+	fowners icinga:icinga /etc/icinga2
+	fowners icinga:icinga /var/lib/icinga2
+	fowners icinga:icinga /var/spool/icinga2
+	fowners icinga:icingacmd /var/lib/icinga2/api
+	fowners icinga:icinga /var/spool/icinga2/perfdata
+	fowners icinga:icingacmd /var/log/icinga2
+
+	fperms ug+rwX,o-rwx /etc/icinga2
+	fperms ug+rwX,o-rwx /var/lib/icinga2
+	fperms ug+rwX,o-rwx /var/spool/icinga2
+	fperms ug+rwX,o-rwx /var/log/icinga2
+
+	if use vim-syntax; then
+		insinto /usr/share/vim/vimfiles
+		doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
+		doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
+	fi
+
+	if use nano-syntax; then
+		insinto /usr/share/nano
+		doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
+	fi
+}
+
+pkg_postinst() {
+	elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
+	elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
+}
-- 
cgit v1.2.3-65-gdbad