From 3c554d94e471d473a8c42f6edcfc2e6b0eb8c7bd Mon Sep 17 00:00:00 2001
From: Matthew Thode <prometheanfire@gentoo.org>
Date: Sat, 9 Jun 2018 13:21:47 -0500
Subject: www-servers/tornado: 4.5.3 and 5.0.2 bups

Package-Manager: Portage-2.3.40, Repoman-2.3.9
---
 www-servers/tornado/Manifest             |  2 +
 www-servers/tornado/tornado-4.5.3.ebuild | 68 ++++++++++++++++++++++++++++++++
 www-servers/tornado/tornado-5.0.2.ebuild | 67 +++++++++++++++++++++++++++++++
 3 files changed, 137 insertions(+)
 create mode 100644 www-servers/tornado/tornado-4.5.3.ebuild
 create mode 100644 www-servers/tornado/tornado-5.0.2.ebuild

(limited to 'www-servers')

diff --git a/www-servers/tornado/Manifest b/www-servers/tornado/Manifest
index 4f21881b7367..80b89045ccf9 100644
--- a/www-servers/tornado/Manifest
+++ b/www-servers/tornado/Manifest
@@ -1,2 +1,4 @@
 DIST tornado-4.4.2.tar.gz 460193 BLAKE2B 4586397e8899af19582e07ac9ecdf56980a552a8c15458f1c16d83dc8ec7bf73b6a1eb341a5402d8555319c3d7528702567d13c4b56a995597e7dba4576f694b SHA512 f330bc62433576708e3c566577cede07c54c19996f374df82d5abc19a669ade549e7b6c27dcae3d421921fec506fae39473443cdb04692553c5ea2f8ec11a327
 DIST tornado-4.5.1.tar.gz 483225 BLAKE2B 261a5da8a7cc43b11b8504162a030fdad9c3c1409d653f86ab37deb5e4398f39ac05bee1da58944c2d1a2fa92dd5894256b748910f90926834305d6c6adf7ab4 SHA512 b31b3572bf58df8b758694c32b2233c547d6600b0c27f56cff3521abaad38a1646a528d2c2dfcf13214159bf5ba0f59470ba3d538edf16dc014a8b03f0d3bb87
+DIST tornado-4.5.3.tar.gz 484221 BLAKE2B 7b3682fa85a7f6ad32351d40993516a3e397b7b0a5de9d807bcd8b2b21325a6170f3670cb13e12aa208b6590313cf165ddf40537dba1fee61fa9d71954265a66 SHA512 c17dd7a3b541c26950d27c8a399ae4fdff1d99d16ff0c5de9871fe2de4c0f797c96712b23b5ed5efdaee06bb251f7def114c83fe6f7f37f344cdac9996d14448
+DIST tornado-5.0.2.tar.gz 506544 BLAKE2B 616298761f5e0cdcacfa96c3a14efaf2cc1d7579d582dc8b2fae2a3a3e45405804aa2a1409665a9af38d2f415908b373c1c34e4ff5868f989bb1bd29fe81a569 SHA512 fbd360df34fe29ed3e5f406992923e2af2815f93446fb9d9810f7575fe06300a2cb15c3f36bd93150284ba297772f94c94a4227acca2dc65c94cf7d100cb5974
diff --git a/www-servers/tornado/tornado-4.5.3.ebuild b/www-servers/tornado/tornado-4.5.3.ebuild
new file mode 100644
index 000000000000..455bb5303a0c
--- /dev/null
+++ b/www-servers/tornado/tornado-4.5.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="http://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+CDEPEND="
+	dev-python/certifi[${PYTHON_USEDEP}]
+	>=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+	$(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' 'python3_4')
+	|| (
+		>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+		(	$(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
+			$(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
+		)
+	)
+	virtual/python-backports_abc[${PYTHON_USEDEP}]
+	virtual/python-futures[${PYTHON_USEDEP}]
+	virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	doc? (
+		dev-python/sphinx[${PYTHON_USEDEP}]
+		dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+	)
+	test? (
+		${CDEPEND}
+		dev-python/mock[${PYTHON_USEDEP}]
+	)
+"
+RDEPEND="${CDEPEND}"
+
+# doc without intersphinx does not build (asyncio error)
+#PATCHES=(
+#	"${FILESDIR}"/4.5.1-drop-intersphinx.patch
+#)
+
+python_compile_all() {
+	use doc && emake -C docs sphinx
+}
+
+python_test() {
+	"${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+	use doc && local HTML_DOCS=( docs/build/html/. )
+	if use examples; then
+		insinto /usr/share/doc/${PF}/examples
+		doins -r demos/.
+		docompress -x /usr/share/doc/${PF}/examples
+fi
+	distutils-r1_python_install_all
+}
diff --git a/www-servers/tornado/tornado-5.0.2.ebuild b/www-servers/tornado/tornado-5.0.2.ebuild
new file mode 100644
index 000000000000..8eec00be8a45
--- /dev/null
+++ b/www-servers/tornado/tornado-5.0.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python web framework and asynchronous networking library"
+HOMEPAGE="http://www.tornadoweb.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+CDEPEND="
+	$(python_gen_cond_dep 'dev-python/futures[${PYTHON_USEDEP}]' 'python2_7')
+	>=dev-python/pycurl-7.19.3.1[${PYTHON_USEDEP}]
+	|| (
+		>=dev-python/twisted-16.0.0[${PYTHON_USEDEP}]
+		(	$(python_gen_cond_dep 'dev-python/twisted-names[${PYTHON_USEDEP}]' 'python2_7')
+			$(python_gen_cond_dep 'dev-python/twisted-web[${PYTHON_USEDEP}]' 'python2_7')
+		)
+	)
+	virtual/python-backports_abc[${PYTHON_USEDEP}]
+	virtual/python-futures[${PYTHON_USEDEP}]
+	virtual/python-singledispatch[${PYTHON_USEDEP}]
+"
+DEPEND="
+	dev-python/setuptools[${PYTHON_USEDEP}]
+	doc? (
+		dev-python/sphinx[${PYTHON_USEDEP}]
+		dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+	)
+	test? (
+		${CDEPEND}
+		dev-python/mock[${PYTHON_USEDEP}]
+	)
+"
+RDEPEND="${CDEPEND}"
+
+# doc without intersphinx does not build (asyncio error)
+#PATCHES=(
+#	"${FILESDIR}"/4.5.1-drop-intersphinx.patch
+#)
+
+python_compile_all() {
+	use doc && emake -C docs sphinx
+}
+
+python_test() {
+	"${PYTHON}" -m tornado.test.runtests || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+	use doc && local HTML_DOCS=( docs/build/html/. )
+	if use examples; then
+		insinto /usr/share/doc/${PF}/examples
+		doins -r demos/.
+		docompress -x /usr/share/doc/${PF}/examples
+fi
+	distutils-r1_python_install_all
+}
-- 
cgit v1.2.3-65-gdbad