aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlice Sell <quarkyalice@disroot.org>2022-07-07 13:04:48 -0700
committerAlice Sell <quarkyalice@disroot.org>2022-07-07 13:08:00 -0700
commit8ac2e455c466f3fc136da27a15a66069ac3e48fc (patch)
tree548234a333b9695ffc6152978b2d8390d584d804 /app-misc/install-date/install-date-9999.ebuild
downloadalicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.gz
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.tar.bz2
alicela1n-8ac2e455c466f3fc136da27a15a66069ac3e48fc.zip
initial commit
Signed-off-by: Alice Sell <quarkyalice@disroot.org>
Diffstat (limited to 'app-misc/install-date/install-date-9999.ebuild')
-rw-r--r--app-misc/install-date/install-date-9999.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/install-date/install-date-9999.ebuild b/app-misc/install-date/install-date-9999.ebuild
new file mode 100644
index 0000000..bfaed02
--- /dev/null
+++ b/app-misc/install-date/install-date-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Determine the install date of Linux installs"
+HOMEPAGE="https://github.com/alicela1n/install-date"
+
+LICENSE="GPL-2"
+SLOT="0"
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/alicela1n/install-date.git"
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/alicela1n/install-date/archive/${PV}.tar.gz"
+fi
+
+IUSE=""
+
+RESTRICT="mirror"
+
+S=${WORKDIR}/install-date-${PV}
+
+DEPEND="
+"
+
+src_install () {
+ exeinto /usr/bin
+ doexe install-date
+}
+