aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/idevicerestore')
-rw-r--r--app-pda/idevicerestore/Manifest3
-rw-r--r--app-pda/idevicerestore/idevicerestore-1.0.0.ebuild54
-rw-r--r--app-pda/idevicerestore/idevicerestore-9999.ebuild54
3 files changed, 111 insertions, 0 deletions
diff --git a/app-pda/idevicerestore/Manifest b/app-pda/idevicerestore/Manifest
new file mode 100644
index 0000000..827c653
--- /dev/null
+++ b/app-pda/idevicerestore/Manifest
@@ -0,0 +1,3 @@
+DIST idevicerestore-1.0.0.tar.bz2 361654 BLAKE2B 7d10a85cf8ba11c75313ff71a14bb5ae49f6fafcad08de350078c26ac87a3c7e40b27fb26d44866c823785b02af3e5d11cdc77b5890315c0b32c7bb0457aa46c SHA512 d62bd498fd12cacc0cd531a31b39255ee71e082a47de234a1d7bfc270745aec3ed18479fd67aeb2ccdc80e09980b98820e62b284c770e092fe24b96f3fca71a2
+EBUILD idevicerestore-1.0.0.ebuild 1255 BLAKE2B 0bdd812d7277e5e2e3ff884137d03da7347254b3cbd0a70a484005f9ca5c6cf9581df44057a0f4c74a0128873c74c9d3a5c759da1f3d7e9cd45d6fb85771dc52 SHA512 58cb6e5751f569fe9049e6f1792f12605215abf7ea3f4c07102bc52528e22f84fd6d99c14de4b3a40cab214e53125ee3a713bd3d146293f93a6a7dc71b5ee103
+EBUILD idevicerestore-9999.ebuild 1255 BLAKE2B 6580bc55357ae130134431f7bf967aa548d0c39bd6a1fb7003d51d48567960a91749eca3b1447a5880415b3bd66bd22ebb738e04ab6dc728e159a6dc5316efcc SHA512 e0a06537a87e7ae913d5019851b42c063aa0ffedbe096e829f0de528c00ef9ea9d2eab1fa02333175fbbf1b32655fb18220a85ad458722ce158cc891f0d7206d
diff --git a/app-pda/idevicerestore/idevicerestore-1.0.0.ebuild b/app-pda/idevicerestore/idevicerestore-1.0.0.ebuild
new file mode 100644
index 0000000..747c091
--- /dev/null
+++ b/app-pda/idevicerestore/idevicerestore-1.0.0.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="A cross-platform tool to restore Apple devices from IPSW files."
+HOMEPAGE="http://libimobiledevice.org"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libimobiledevice/${PN}"
+else
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+fi
+
+S="${WORKDIR}/idevicerestore-${PV}"
+
+LICENSE="GPL-3 LGPL-3.0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+SLOT="0/6"
+KEYWORDS=""
+
+RESTRICT="mirror"
+
+RDEPEND=">=app-pda/libirecovery-1.0.0
+ >=app-pda/libimobiledevice-1.3.0
+ app-pda/libplist
+ >=dev-libs/libzip-0.8.0
+ >=net-misc/curl-7.0.0
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS INSTALL NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # the software's configure.ac doesn't handle things quite correctly,
+ # pass -pthread and -lpthread to solve the issue
+ append-flags "-pthread"
+ append-ldflags "-lpthread"
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman docs/idevicerestore.1
+ find "${D}" -name '*.la' -delete || die
+}
diff --git a/app-pda/idevicerestore/idevicerestore-9999.ebuild b/app-pda/idevicerestore/idevicerestore-9999.ebuild
new file mode 100644
index 0000000..2c4dab1
--- /dev/null
+++ b/app-pda/idevicerestore/idevicerestore-9999.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2021 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="A cross-platform tool to restore Apple devices from IPSW files."
+HOMEPAGE="http://libimobiledevice.org"
+if [[ ${PV} == 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/libimobiledevice/${PN}"
+else
+ RESTRICT="mirror"
+ SRC_URI="https://github.com/libimobiledevice/${PN}/releases/download/${PV}/${P}.tar.bz2"
+fi
+
+S="${WORKDIR}/idevicerestore-${PV}"
+
+LICENSE="GPL-3 LGPL-3.0"
+KEYWORDS="~amd64 ~x86 ~arm ~arm64"
+SLOT="0/6"
+KEYWORDS=""
+
+RESTRICT="mirror"
+
+RDEPEND=">=app-pda/libirecovery-1.0.1
+ >=app-pda/libimobiledevice-1.3.0
+ app-pda/libplist
+ >=dev-libs/libzip-0.8.0
+ >=net-misc/curl-7.0.0
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS INSTALL NEWS README TODO )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # the software's configure.ac doesn't handle things quite correctly,
+ # pass -pthread and -lpthread to solve the issue
+ append-flags "-pthread"
+ append-ldflags "-lpthread"
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ doman docs/idevicerestore.1
+ find "${D}" -name '*.la' -delete || die
+}