aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/django-pipeline/django-pipeline-1.2.6.ebuild')
-rw-r--r--dev-python/django-pipeline/django-pipeline-1.2.6.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
index 7d63045..74ecf7e 100644
--- a/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
+++ b/dev-python/django-pipeline/django-pipeline-1.2.6.ebuild
@@ -1,3 +1,4 @@
+
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
@@ -5,7 +6,7 @@
EAPI=4
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS=1
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -18,7 +19,7 @@ IUSE="doc"
LICENSE="MIT"
SLOT="0"
PYTHON_MODNAME="pipeline"
-
+DISTUTILS_SRC_TEST=nosetests
RDEPEND=">=dev-python/django-1.4"
DEPEND="${RDEPEND}
dev-python/setuptools"
@@ -37,7 +38,7 @@ src_test() {
pushd build-${PYTHON_ABI}/lib/tests/tests/ > /dev/null || die
for test in [a-z]*.py
do
- if ! PYTHONPATH=./../ "$(PYTHON)" ${test}; then
+ if ! "$(PYTHON)" ${test}; then
eerror "test "${test}" failed"
exit_status="1"
else
@@ -54,10 +55,7 @@ src_install() {
distutils_src_install
if use doc; then
- docompress -x usr/share/doc/${P}/doctrees
dohtml -r docs/_build/html/
- insinto usr/share/doc/${P}/doctrees
- doins docs/_build/doctrees/*
fi
# Remove un-needed tests to avoid file collisions