summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2012-07-25 01:51:51 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:12 +0200
commit1797c5f839694f32fd962f0b4594de230f8e1280 (patch)
treeea94a8473e313ce464674a381c7fb73779a9e9ac /dev-cpp
parentBump less. Use l10n eclass. Update checksums (diff)
downloadmv-1797c5f839694f32fd962f0b4594de230f8e1280.tar.gz
mv-1797c5f839694f32fd962f0b4594de230f8e1280.tar.bz2
mv-1797c5f839694f32fd962f0b4594de230f8e1280.zip
Add cpplint. Install site file for mv_emcacs
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/cpplint/Manifest4
-rw-r--r--dev-cpp/cpplint/cpplint-3.199.ebuild74
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-cpp/cpplint/Manifest b/dev-cpp/cpplint/Manifest
new file mode 100644
index 00000000..b6dad05f
--- /dev/null
+++ b/dev-cpp/cpplint/Manifest
@@ -0,0 +1,4 @@
+DIST cpplint-3.199.el 5800 SHA256 4ca96554c60501ddc1c9d6759ae8cb16e24019f8a74354590ea042dfb7a543be SHA512 7cbb2f587384cd7b371e8b761e937b1975924bfd23fdaaf27d1816effc9a8def2e1961a40a96d01ae16a431726f91c3a93887bccfe75440a9dde2f4ab895f8b6 WHIRLPOOL 599b8e3346037085b1b869b8cd59ca9b95afb82b79946fe0b875f2710af543239ae45995a451ea10fa62abaef4bd1f384ecfee093856ddce2936791545b83d2b
+DIST cpplint-3.199.py 133876 SHA256 90b33b3dc7aa9e5ed4a73418be83f0bb1c13e2a47ae977ee81560d5b11d799b5 SHA512 1d27b0352f6d0db084c7da28de1b647871c6eab5a442db9c55592fed758a56a11a3077c0e89ef5c03b94a4c235981d3fbfacc1a8180e9de8100c13a4f3223557 WHIRLPOOL 2d734ac2424129b068eaebe756b0a2450ab95a4edea6afff4e3f3737225a16e459cdbfbd980b7745dee8bf07e751c110671f0a470e27dbf65bd99310b7f172c0
+DIST cpplint-3.199.txt 2228 SHA256 1c0500c633b2161633abffccc942f8b18dddb04a9b099d40db09b959078044c8 SHA512 29507d5a714b08027cc6d1412639e71c206a0167b7b3fae3e8ebaf48717fc93b2838d132a5f0e327b767c138e5735cc472b6f2515cce1f932507324065563687 WHIRLPOOL 1713897d18d8795121660061c58d87bc23f39a4c7de069b37cfe6de8e837adf5d1065cedc4e54894be722df8a8a9ebd306814fd769365f03343a6c897cd86cbd
+DIST cpplint-3.199.xml 175939 SHA256 70b8fcd37ad0f8d0489adc91887c9405c66fc05d0effb532878deae78fb9e758 SHA512 0d4e98b3803146faf14edbf3b57f3760a19b9a4be1af26527ab4625e462250a5e659b593828cc69d268c6aac81326214f3192968e9fc6855037ebecdf04798f6 WHIRLPOOL cc33266a60f2d558eb8c96c443fe858e5961cde1a17a379219474f738d0335388879f89056a48a50cf7d1bc59c4fb9699160a325f89a4f59017fb81d400d7879
diff --git a/dev-cpp/cpplint/cpplint-3.199.ebuild b/dev-cpp/cpplint/cpplint-3.199.ebuild
new file mode 100644
index 00000000..2feb2f3e
--- /dev/null
+++ b/dev-cpp/cpplint/cpplint-3.199.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=4
+
+inherit elisp-common eutils
+
+DESCRIPTION="The google styleguide for C++ together with a verifyer and an emacs file"
+HOMEPAGE="http://code.google.com/p/google-styleguide/"
+SRC_URI="http://google-styleguide.googlecode.com/svn/trunk/cppguide.xml -> cpplint-${PV}.xml
+ http://google-styleguide.googlecode.com/svn/trunk/cpplint/cpplint.py -> cpplint-${PV}.py
+ http://google-styleguide.googlecode.com/svn/trunk/cpplint/README -> cpplint-${PV}.txt
+ emacs? ( http://google-styleguide.googlecode.com/svn/trunk/google-c-style.el -> cpplint-${PV}.el )"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="emacs"
+
+EMACSNAME="google-c-style"
+COMMON="emacs? ( virtual/emacs )"
+DEPEND="${COMMON}"
+RDEPEND="dev-lang/python
+ ${COMMON}"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ cp -- "${DISTDIR}/cpplint-${PV}.xml" cppguide.xml || die
+ cp -- "${DISTDIR}/cpplint-${PV}.py" cpplint.py || die
+ cp -- "${DISTDIR}/cpplint-${PV}.txt" README || die
+ if use emacs
+ then cp -- "${DISTDIR}/cpplint-${PV}.el" "${EMACSNAME}.el" || die
+ mkdir sitefile
+ cat >"sitefile/50${EMACSNAME}-gentoo.el" <<EOF
+(add-to-list 'load-path "@SITELISP@")
+(autoload 'google-set-c-style "${EMACSNAME}"
+ "Set the current buffer's c-style to Google C/C++ Programming
+ Style. Meant to be added to \`c-mode-common-hook'." t)
+(add-hook 'c-mode-common-hook 'google-set-c-style)
+
+; If you want the RETURN key to go to the next line and space over
+; to the right place, uncomment the following line
+;(add-hook 'c-mode-common-hook 'google-make-newline-indent)
+EOF
+ fi
+}
+
+src_prepare() {
+ epatch_user
+}
+
+src_compile() {
+ if use emacs
+ then elisp-compile *.el || die
+ fi
+}
+
+src_install() {
+ dobin cpplint.py
+ dodoc README cppguide.xml
+ if use emacs
+ then elisp-install "${EMACSNAME}" "${EMACSNAME}".{el,elc} || die
+ elisp-site-file-install "sitefile/50${EMACSNAME}-gentoo.el" "${EMACSNAME}" || die
+ fi
+}
+
+pkg_postinst() {
+ elisp-site-regen
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}