summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Väth <martin@mvath.de>2013-10-12 21:12:31 +0200
committerMartin Väth <martin@mvath.de>2015-10-11 10:48:59 +0200
commit5d21146b66819048d79903a55a151e52fc64749c (patch)
tree8f7da4a59d3c1d8a91d1f9f194285e38e81fd29d /x11-themes
parentBump firewall-mv (diff)
downloadmv-5d21146b66819048d79903a55a151e52fc64749c.tar.gz
mv-5d21146b66819048d79903a55a151e52fc64749c.tar.bz2
mv-5d21146b66819048d79903a55a151e52fc64749c.zip
Add fvwm-crystal. Use readme.gentoo.eclass
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/fvwm-crystal/ChangeLog9
-rw-r--r--x11-themes/fvwm-crystal/Manifest1
-rw-r--r--x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild108
-rw-r--r--x11-themes/fvwm-crystal/metadata.xml21
4 files changed, 139 insertions, 0 deletions
diff --git a/x11-themes/fvwm-crystal/ChangeLog b/x11-themes/fvwm-crystal/ChangeLog
new file mode 100644
index 00000000..2817b8e4
--- /dev/null
+++ b/x11-themes/fvwm-crystal/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for x11-themes/fvwm-crystal
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: $
+
+*fvwm-crystal-3.2.7 (12 Oct 2013)
+
+ 12 Oct 2013; Martin Väth <martin@mvath.de>:
+ Fork from main tree to get earlier revbump: In particular, bashisms are
+ fixed in newer versions of fvwm-crystal. Removing previous ChangeLog.
diff --git a/x11-themes/fvwm-crystal/Manifest b/x11-themes/fvwm-crystal/Manifest
new file mode 100644
index 00000000..8e9cea5e
--- /dev/null
+++ b/x11-themes/fvwm-crystal/Manifest
@@ -0,0 +1 @@
+DIST fvwm-crystal-3.2.7.tar.gz 4461495 SHA256 fd3ef491a092af36060516907628744545486cb6f33bcdd738ffc9e2bb73b6e1 SHA512 4c5608d4b47df65cf8bcc4d17137dfaa006f1d332a9e33fec77e15ab7872449d94e2b9cac8e667cfd702032f6bada1327f0f14d113fd07fe0aa130ec6838f560 WHIRLPOOL ddb8f8bfbb2e9af2422db4591ab3aeeb6c1bc76de320ae1673c226bd2dd17787238fb37d47cf3901ab20e7ead05b98205895aadc6eca023398b69b6cbe2580c4
diff --git a/x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild
new file mode 100644
index 00000000..43a466d6
--- /dev/null
+++ b/x11-themes/fvwm-crystal/fvwm-crystal-3.2.7.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/fvwm-crystal/fvwm-crystal-3.2.3.ebuild,v 1.1 2013/06/23 10:00:55 hwoarang Exp $
+
+EAPI="5"
+RESTRICT=mirror
+
+PYTHON_COMPAT=( python2_7 )
+inherit eutils readme.gentoo python-r1
+
+DESCRIPTION="Configurable and full featured FVWM theme, with lots of transparency and freedesktop compatible menu"
+HOMEPAGE="http://fvwm-crystal.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+#http://sourceforge.net/projects/fvwm-crystal/files/3.2.7/fvwm-crystal-3.2.7.tar.gz/download
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}
+ >=x11-wm/fvwm-2.6.5[png]
+ || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( >=x11-misc/stalonetray-0.6.2-r2 x11-misc/trayer )
+ || ( x11-misc/hsetroot media-gfx/feh )
+ sys-apps/sed
+ sys-devel/bc
+ virtual/awk
+ x11-apps/xwd"
+
+DISABLE_AUTOFORMATTING="true"
+DOC_CONTENTS="After installation, execute following commands:
+ $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xresources ~/.Xresources
+ $ cp -r ${ROOT}usr/share/doc/${PF}/addons/Xsession ~/.xinitrc
+
+Many applications can extend functionality of fvwm-crystal.
+They are listed in ${ROOT}usr/share/doc/${PF}/INSTALL.gz.
+
+Some icons fixes was committed recently.
+To archive the same fixes on your private icon files,
+please read ${ROOT}usr/share/doc/${PF}/INSTALL.gz.
+This will fix the libpng warnings at stderr.
+
+The color themes was updated to Fvwm InfoStore.
+To know how to update your custom color themes, please run
+ ${ROOT}usr/share/${PN}/addons/convert_colorsets"
+
+src_prepare() {
+ find "${S}" -type d -name Applications -prune \
+ -o -type f -exec /bin/sh -c 'Echo() {
+ printf '\''%s\n'\'' "${*}"
+}
+Sed() {
+ text=${1:-bashisms}
+ shift
+ cp -p -- "${i}" "${i}.patched" && \
+ sed "${@}" \
+ -e '\''s/echo -e/echo/'\'' \
+ -e '\''s/\[\[ /\[ /g'\'' \
+ -e '\''s/ \]\]/ \]/g'\'' \
+ -e '\''/\[ | \]/{s/==/=/g}'\'' \
+ -e '\''s/source \([^a-z]\)/. \1/g'\'' \
+ -- "${i}" >|"${i}.patched" && \
+ if diff -q -- "${i}.patched" "${i}" >/dev/null 2>&1
+ then rm -f -- "${i}.patched"
+ else Echo "Fixing ${text} in ${i}"
+ mv -- "${i}.patched" "${i}"
+ fi && return
+ Echo "Failed to patch ${i}" >&2
+ exit 1
+}
+for i
+do case ${i} in
+ *.html|*.py|*.png|*.gif|*.jpg|*/ChangeLog)
+ continue;;
+ */fvwm-crystal)
+ Sed break -e '\''/break;/d'\''
+ continue;;
+ */DesktopActions)
+ Sed arrays \
+ -e '\''/Execs=/{s/[()]/'\''"'\''/g}" \
+ -e '\''s/Execs\[\*\]/Execs/'\''
+ continue;;
+ */fvwm-crystal.videomodeswitch*)
+ Sed shebang -e '\''s:^#!/bin/sh:#!/bin/bash:'\''
+ continue;;
+ esac
+ head -n1 -- "${i}" | grep bash >/dev/null && continue
+ if grep -q '\''echo \*'\'' -- "${i}" >/dev/null
+ then Sed quoting -e '\''s/echo \*/echo \\*/g'\''
+ else Sed ""
+ fi
+done' sh '{}' '+' || die "patching failed"
+ epatch_user
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir="/usr/share/doc/${PF}" \
+ prefix="/usr" \
+ install
+
+ python_replicate_script \
+ "${D}/usr/bin/${PN}".{apps,wallpaper} \
+ "${D}/usr/share/${PN}"/fvwm/scripts/FvwmMPD/*.py
+ readme.gentoo_src_install
+}
diff --git a/x11-themes/fvwm-crystal/metadata.xml b/x11-themes/fvwm-crystal/metadata.xml
new file mode 100644
index 00000000..5f357c6b
--- /dev/null
+++ b/x11-themes/fvwm-crystal/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>dominique.michel@vtxnet.ch</email>
+ <name>Dominique Michel</name>
+</maintainer>
+<longdescription>
+FVWM-Crystal is a set of configuration files for FVWM window manager,
+with additional programs and scripts. Some of it's features are:
+ * quick launching of a terminal with just one click on a desktop
+ * a specially configured terminal window, similar to a console from FPP games
+ * builtin control over XMMS player and over aumix mixer from the keyboard and
+ buttons on the screen
+ * very good ability to control the desktop from the keyboard, including window
+ switching, moving, shading/unshading, maximizing, resizing, moving between
+ desktop pages
+ * transparent window titlebars, menus and panels on the desktop
+</longdescription>
+</pkgmetadata>