summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Duft <mduft@gentoo.org>2011-07-13 09:05:48 +0000
committerMarkus Duft <mduft@gentoo.org>2011-07-13 09:05:48 +0000
commit00672a33e0b37168ad390e36c07c0db0b260fcbe (patch)
treef4c2506e1d2e94fa493ed728703312bf510619c9
parentMigrated to new git-2.eclass. (diff)
downloadgentoo-2-00672a33e0b37168ad390e36c07c0db0b260fcbe.tar.gz
gentoo-2-00672a33e0b37168ad390e36c07c0db0b260fcbe.tar.bz2
gentoo-2-00672a33e0b37168ad390e36c07c0db0b260fcbe.zip
added patch required for interix prefix build - upstream committed already.
(Portage version: 2.1.10.3/cvs/Linux i686)
-rw-r--r--x11-libs/cairo/ChangeLog6
-rw-r--r--x11-libs/cairo/cairo-1.10.2-r1.ebuild3
-rw-r--r--x11-libs/cairo/files/cairo-1.10.2-interix.patch36
3 files changed, 43 insertions, 2 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index b929546a06de..13bb5514d26b 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/cairo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.282 2011/07/03 10:45:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.283 2011/07/13 09:05:48 mduft Exp $
+
+ 13 Jul 2011; Markus Duft <mduft@gentoo.org> cairo-1.10.2-r1.ebuild,
+ +files/cairo-1.10.2-interix.patch:
+ added patch required for interix prefix build - upstream committed already.
03 Jul 2011; Raúl Porcel <armin76@gentoo.org> cairo-1.10.2-r1.ebuild,
cairo-9999.ebuild:
diff --git a/x11-libs/cairo/cairo-1.10.2-r1.ebuild b/x11-libs/cairo/cairo-1.10.2-r1.ebuild
index 53f72976ccd6..492794ebc44f 100644
--- a/x11-libs/cairo/cairo-1.10.2-r1.ebuild
+++ b/x11-libs/cairo/cairo-1.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.10.2-r1.ebuild,v 1.12 2011/07/03 10:45:00 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.10.2-r1.ebuild,v 1.13 2011/07/13 09:05:48 mduft Exp $
EAPI=3
@@ -64,6 +64,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
epatch "${FILESDIR}"/${PN}-1.10.0-buggy_gradients.patch
+ epatch "${FILESDIR}"/${P}-interix.patch
# Slightly messed build system YAY
if [[ ${PV} == *9999* ]]; then
diff --git a/x11-libs/cairo/files/cairo-1.10.2-interix.patch b/x11-libs/cairo/files/cairo-1.10.2-interix.patch
new file mode 100644
index 000000000000..3333e3ee5256
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.10.2-interix.patch
@@ -0,0 +1,36 @@
+commit 95f6f7a174ca096a3d3dbe84ff220d166d1e2baa
+Author: Uli Schlachter <psychon@znc.in>
+Date: Fri Oct 22 11:54:57 2010 +0200
+
+ Make both versions of _cairo_lround consistent again
+
+ Commit c0008242b0f made cairo use libm's lround instead of its own _cairo_lround
+ by default. However, since commit ce58f874 from 2006, _cairo_lround does
+ arithmetic rounding instead of away-from-zero rounding (before said commit, it
+ was using baker's rounding).
+
+ So to make the rounding of _cairo_lround be independent from
+ DISABLE_SOME_FLOATING_POINT, we have to use another function. Turns out that
+ _cairo_round already does the same thing that _cairo_lround does. Their only
+ difference is the return type.
+
+ Signed-off-by: Uli Schlachter <psychon@znc.in>
+ Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+
+diff --git a/src/cairoint.h b/src/cairoint.h
+index 53c87e5..539d92e 100644
+--- a/src/cairoint.h
++++ b/src/cairoint.h
+@@ -968,7 +968,11 @@ _cairo_round (double r)
+ cairo_private int
+ _cairo_lround (double d) cairo_const;
+ #else
+-#define _cairo_lround lround
++static inline int cairo_const
++_cairo_lround (double r)
++{
++ return _cairo_round (r);
++}
+ #endif
+
+ cairo_private uint16_t