summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Bergmann <sebastian@gentoo.org>2005-10-13 21:35:50 +0000
committerSebastian Bergmann <sebastian@gentoo.org>2005-10-13 21:35:50 +0000
commit06f05c1eb0d416d7cf220138298a16688293b199 (patch)
tree480ff44cc65b383722ad39d6227992a983d2a911
parentMarking gnome-volume-manager-1.5.3 as ~ppc64 for 108796 (diff)
downloadgentoo-2-06f05c1eb0d416d7cf220138298a16688293b199.tar.gz
gentoo-2-06f05c1eb0d416d7cf220138298a16688293b199.tar.bz2
gentoo-2-06f05c1eb0d416d7cf220138298a16688293b199.zip
Pull jpgraph-1.19 as requested by Brian Harring for bug 107467.
(Portage version: 2.0.53_rc5)
-rw-r--r--dev-php/jpgraph/ChangeLog6
-rw-r--r--dev-php/jpgraph/files/digest-jpgraph-1.191
-rw-r--r--dev-php/jpgraph/jpgraph-1.19.ebuild75
3 files changed, 5 insertions, 77 deletions
diff --git a/dev-php/jpgraph/ChangeLog b/dev-php/jpgraph/ChangeLog
index 3021cbd09561..efc5e2aed340 100644
--- a/dev-php/jpgraph/ChangeLog
+++ b/dev-php/jpgraph/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-php/jpgraph
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/ChangeLog,v 1.18 2005/10/11 04:51:36 sebastian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/ChangeLog,v 1.19 2005/10/13 21:35:50 sebastian Exp $
+
+ 13 Oct 2005; Sebastian Bergmann <sebastian@gentoo.org>
+ -jpgraph-1.19.ebuild:
+ Pull jpgraph-1.19 as requested by Brian Harring for bug 107467.
*jpgraph-1.19-r1 (11 Oct 2005)
diff --git a/dev-php/jpgraph/files/digest-jpgraph-1.19 b/dev-php/jpgraph/files/digest-jpgraph-1.19
deleted file mode 100644
index 6eadd10a3e42..000000000000
--- a/dev-php/jpgraph/files/digest-jpgraph-1.19
+++ /dev/null
@@ -1 +0,0 @@
-MD5 fc364e1b56dea32bdace47411085cd72 jpgraph-1.19.tar.gz 4068179
diff --git a/dev-php/jpgraph/jpgraph-1.19.ebuild b/dev-php/jpgraph/jpgraph-1.19.ebuild
deleted file mode 100644
index b4c8296afeef..000000000000
--- a/dev-php/jpgraph/jpgraph-1.19.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/jpgraph/jpgraph-1.19.ebuild,v 1.1 2005/07/16 14:08:14 sebastian Exp $
-
-inherit php-lib
-
-DESCRIPTION="fully OO graph drawing library for PHP"
-HOMEPAGE="http://www.aditus.nu/jpgraph/"
-SRC_URI="http://members.chello.se/jpgraph/jpgdownloads/${P}.tar.gz"
-
-LICENSE="QPL-1.0"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
-IUSE=""
-
-DEPEND="$DEPEND =dev-php/php-4*"
-RDEPEND="virtual/php"
-
-JPGRAPH_CACHE_DIR="/var/cache/jpgraph"
-
-HTTPD_USER=root
-HTTPD_GROUP=root
-
-has_version "net-www/apache" && USE_APACHE=1 && inherit webapp-apache
-[ -n "${USE_APACHE}" ] && webapp-detect || NO_WEBSERVER=1
-
-pkg_setup() {
- if [ "${NO_WEBSERVER}" = "1" ]; then
- ewarn "No webserver detected - ${JPGRAPH_CACHE_DIR} will be"
- ewarn "owned by ${HTTPD_USER} instead"
- else
- einfo "Configuring cache dir ${JPGRAPH_CACHE_DIR} for ${WEBAPP_SERVER}"
- fi
-}
-
-src_install() {
- einfo "Patching jpgraph.php"
-
- # patch 1:
- # make jpgraph use the correct group for file permissions
-
- sed -i "s|^DEFINE(\"CACHE_FILE_GROUP\",\"wwwadmin\");|DEFINE(\"CACHE_FILE_GROUP\", \"${HTTPD_GROUP}\");|" src/jpgraph.php
-
- # patch 2:
- # make jpgraph use the correct directory for caching
-
- sed -i "s|/tmp/jpgraph_cache/|${JPGRAPH_CACHE_DIR}/|g;" src/jpgraph.php
-
- # patch 3:
- # switch off the directory cache
-
- sed -i 's|^DEFINE("USE_CACHE",false);|if (!defined("USE_CACHE")) DEFINE("USE_CACHE", false);|' src/jpgraph.php
-
- # patch 4:
- # don't read the READ_CACHE if we're not creating any images in the
- # cache in the first place (doh)
-
- sed -i 's|DEFINE("READ_CACHE",true);|DEFINE("READ_CACHE", USE_CACHE);|' src/jpgraph.php
-
- # install php files
- einfo "Building list of files to install"
- php-lib_src_install src `cd src ; find . -type f -print`
-
- # install documentation
- dodoc README QPL.txt
- dohtml -r docs/*
-
- # setup the cache dir
- # cachedir must be world-writable, because PHP/CLI doesn't run
- # as the apache user!
-
- keepdir "${JPGRAPH_CACHE_DIR}"
- fowners ${HTTPD_USER}:${HTTPD_GROUP} "${JPGRAPH_CACHE_DIR}"
- fperms 700 "${JPGRAPH_CACHE_DIR}"
-}