summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2013-07-14 08:03:44 +0000
committerHans de Graaff <graaff@gentoo.org>2013-07-14 08:03:44 +0000
commit0999e5181a068cda02530488662ff26e792f9d3b (patch)
tree4a239b2255f0b0350cfe844a90c105d846790ce2
parentCleanup. (diff)
downloadgentoo-2-0999e5181a068cda02530488662ff26e792f9d3b.tar.gz
gentoo-2-0999e5181a068cda02530488662ff26e792f9d3b.tar.bz2
gentoo-2-0999e5181a068cda02530488662ff26e792f9d3b.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0x8883FA56A308A8D7!)
-rw-r--r--dev-ruby/date_validator/ChangeLog7
-rw-r--r--dev-ruby/date_validator/date_validator-0.7.0.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/dev-ruby/date_validator/ChangeLog b/dev-ruby/date_validator/ChangeLog
index 0c29d3f966a3..23c67ecec45f 100644
--- a/dev-ruby/date_validator/ChangeLog
+++ b/dev-ruby/date_validator/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ruby/date_validator
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.3 2013/07/14 08:02:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/ChangeLog,v 1.4 2013/07/14 08:03:44 graaff Exp $
+
+*date_validator-0.7.0 (14 Jul 2013)
+
+ 14 Jul 2013; Hans de Graaff <graaff@gentoo.org> +date_validator-0.7.0.ebuild:
+ Version bump.
14 Jul 2013; Hans de Graaff <graaff@gentoo.org> -date_validator-0.6.3.ebuild:
Cleanup.
diff --git a/dev-ruby/date_validator/date_validator-0.7.0.ebuild b/dev-ruby/date_validator/date_validator-0.7.0.ebuild
new file mode 100644
index 000000000000..e58c9ce902b3
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.7.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/date_validator/date_validator-0.7.0.ebuild,v 1.1 2013/07/14 08:03:44 graaff Exp $
+
+EAPI=5
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+HOMEPAGE="http://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+}