summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-02 23:59:34 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2011-11-02 23:59:34 +0000
commit0bffae1c8a63e8c60877c8f2f8e0bcb014679891 (patch)
tree4aaf182b27f9421784d7618120c7c3fb7704e55d
parentAdd CCPL-Attribution-2.5 to FREE-DOCUMENTS license group, acked by robbat2. (diff)
downloadgentoo-2-0bffae1c8a63e8c60877c8f2f8e0bcb014679891.tar.gz
gentoo-2-0bffae1c8a63e8c60877c8f2f8e0bcb014679891.tar.bz2
gentoo-2-0bffae1c8a63e8c60877c8f2f8e0bcb014679891.zip
New ebuild for bug #352188, formerly maintained in Sunrise.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
-rw-r--r--games-util/pyfa/ChangeLog11
-rw-r--r--games-util/pyfa/files/configforced.py4
-rw-r--r--games-util/pyfa/files/pyfa-1.0.3-staticPath.patch15
-rw-r--r--games-util/pyfa/files/pyfa.desktop8
-rw-r--r--games-util/pyfa/metadata.xml17
-rw-r--r--games-util/pyfa/pyfa-1.0.6.ebuild70
6 files changed, 125 insertions, 0 deletions
diff --git a/games-util/pyfa/ChangeLog b/games-util/pyfa/ChangeLog
new file mode 100644
index 000000000000..1eb4bf94a37b
--- /dev/null
+++ b/games-util/pyfa/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for games-util/pyfa
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/ChangeLog,v 1.1 2011/11/02 23:59:34 tetromino Exp $
+
+*pyfa-1.0.6 (02 Nov 2011)
+
+ 02 Nov 2011; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +files/pyfa-1.0.3-staticPath.patch, +pyfa-1.0.6.ebuild,
+ +files/configforced.py, +files/pyfa.desktop, +metadata.xml:
+ New ebuild for bug #352188, formerly maintained in Sunrise.
+
diff --git a/games-util/pyfa/files/configforced.py b/games-util/pyfa/files/configforced.py
new file mode 100644
index 000000000000..a8008c217eda
--- /dev/null
+++ b/games-util/pyfa/files/configforced.py
@@ -0,0 +1,4 @@
+# Gentoo-specific settings
+pyfaPath = u'%%SITEDIR%%/pyfa'
+staticPath = u'%%EPREFIX%%/usr/share/pyfa/staticdata'
+gameDB = staticPath + "/eve.db"
diff --git a/games-util/pyfa/files/pyfa-1.0.3-staticPath.patch b/games-util/pyfa/files/pyfa-1.0.3-staticPath.patch
new file mode 100644
index 000000000000..4eff73006c62
--- /dev/null
+++ b/games-util/pyfa/files/pyfa-1.0.3-staticPath.patch
@@ -0,0 +1,15 @@
+Make staticPath settable from configforced
+
+--- a/config.py
++++ b/config.py
+@@ -30,7 +30,9 @@ if savePath is None:
+ savePath = unicode(os.path.expanduser(os.path.join("~", ".pyfa")), sys.getfilesystemencoding())
+
+ # Static EVE Data from the staticdata repository, should be in the staticdata directory in our pyfa directory
+-staticPath = os.path.join(pyfaPath, "staticdata")
++staticPath = getattr(configforced, "staticPath", None)
++if staticPath is None:
++ staticPath = os.path.join(pyfaPath, "staticdata")
+
+ # The database where we store all the fits etc
+ saveDB = os.path.join(savePath, "saveddata.db")
diff --git a/games-util/pyfa/files/pyfa.desktop b/games-util/pyfa/files/pyfa.desktop
new file mode 100644
index 000000000000..07f3f0ee22a7
--- /dev/null
+++ b/games-util/pyfa/files/pyfa.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Pyfa
+Comment=Ship fitting application for EVE Online
+Icon=pyfa
+Terminal=false
+Type=Application
+Categories=Game;RolePlaying;
+Exec=pyfa
diff --git a/games-util/pyfa/metadata.xml b/games-util/pyfa/metadata.xml
new file mode 100644
index 000000000000..36dc9b2dff22
--- /dev/null
+++ b/games-util/pyfa/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>tetromino@gentoo.org</email>
+ <name>Alexandre Rostovtsev</name>
+</maintainer>
+<longdescription lang="en">
+Pyfa is the Python Fitting Assistant, a standalone application for creating
+fittings for the EVE Online SciFi MMORPG. It provides many advanced features
+such as graphs and full calculations of any possible combination of modules,
+fits, etc.
+</longdescription>
+<use>
+ <flag name="graph">Enable support for graphs</flag>
+</use>
+</pkgmetadata>
diff --git a/games-util/pyfa/pyfa-1.0.6.ebuild b/games-util/pyfa/pyfa-1.0.6.ebuild
new file mode 100644
index 000000000000..e73a95f79917
--- /dev/null
+++ b/games-util/pyfa/pyfa-1.0.6.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/pyfa/pyfa-1.0.6.ebuild,v 1.1 2011/11/02 23:59:34 tetromino Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2:2.6"
+PYTHON_USE_WITH="sqlite threads"
+
+inherit eutils python
+
+if [[ ${PV/_rc*/} == ${PV} ]] ; then
+ MY_PV=${PV}-incarna-src
+ FOLDER=stable/${PV}
+else
+ MY_PV=${PV/_rc/-stable-RC}-src
+ FOLDER=stable/${PV/*_rc/RC}
+fi
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="http://www.evefit.org/Pyfa"
+SRC_URI="http://dl.evefit.org/${FOLDER}/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-2.1 CCPL-Attribution-2.5 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+graph"
+
+RDEPEND="dev-python/sqlalchemy
+ >=dev-python/wxpython-2.8
+ graph? ( dev-python/matplotlib[wxwidgets] dev-python/numpy )"
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # make staticPath settable from configforced again
+ epatch "${FILESDIR}/${PN}-1.0.3-staticPath.patch"
+
+ python_convert_shebangs -r -x 2 .
+ sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+ -e "s:%%EPREFIX%%:${EPREFIX}:" \
+ "${FILESDIR}/configforced.py" > configforced.py
+}
+
+src_install() {
+ local packagedir=$(python_get_sitedir)/${PN}
+ insinto "${packagedir}"
+ doins -r eos gui icons service config*.py info.py gpl.txt
+ exeinto "${packagedir}"
+ doexe ${PN}.py
+ dosym "${packagedir}/${PN}.py" /usr/bin/${PN}
+ insinto /usr/share/${PN}
+ doins -r staticdata
+ dodoc readme.txt
+ doicon icons/${PN}.png
+ domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_postinst() {
+ python_mod_optimize ${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${PN}
+}