summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-03-28 12:45:48 +0000
committerIan Delaney <idella4@gentoo.org>2014-03-28 12:45:48 +0000
commit0c11d574fd8d04d8d274590687737751596e47b5 (patch)
tree2fc4db580bf09b7d1946bb02b78ebdb24200b435
parentBackport multilib libgudev, bug #506002 (diff)
downloadgentoo-2-0c11d574fd8d04d8d274590687737751596e47b5.tar.gz
gentoo-2-0c11d574fd8d04d8d274590687737751596e47b5.tar.bz2
gentoo-2-0c11d574fd8d04d8d274590687737751596e47b5.zip
revbump, bump; fix broken tests with new patch, fixes Bug #49748 by our Patrick
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
-rw-r--r--dev-python/egenix-mx-base/ChangeLog11
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild6
-rw-r--r--dev-python/egenix-mx-base/egenix-mx-base-3.2.7.ebuild71
-rw-r--r--dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch34
4 files changed, 118 insertions, 4 deletions
diff --git a/dev-python/egenix-mx-base/ChangeLog b/dev-python/egenix-mx-base/ChangeLog
index be13a7983e67..9cd3bdc2cc97 100644
--- a/dev-python/egenix-mx-base/ChangeLog
+++ b/dev-python/egenix-mx-base/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/egenix-mx-base
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/ChangeLog,v 1.84 2013/10/22 11:44:41 grobian Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/ChangeLog,v 1.85 2014/03/28 12:45:47 idella4 Exp $
+
+*egenix-mx-base-3.2.7 (28 Mar 2014)
+
+ 28 Mar 2014; Ian Delaney <idella4@gentoo.org> +egenix-mx-base-3.2.7.ebuild,
+ +files/egenix-mx-base-3.2.6-tests.patch, egenix-mx-base-3.2.6.ebuild:
+ revbump, bump; fix broken tests with new patch, fixes Bug #49748 by our
+ Patrick
22 Oct 2013; Fabian Groffen <grobian@gentoo.org> egenix-mx-base-3.2.6.ebuild:
Marked ~x64-macos, bug #487670
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild
index daadc37192d3..48cc8fb82965 100644
--- a/dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild,v 1.4 2013/10/22 11:44:41 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.2.6.ebuild,v 1.5 2014/03/28 12:45:47 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
@@ -15,6 +15,8 @@ LICENSE="eGenixPublic-1.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
IUSE=""
+# Correct broken tests
+PATCHES=( "${FILESDIR}"/${P}-tests.patch )
# distutils.command.config writes to CWD, bug #450516
# mxSetup.py is broken with --build-lib
diff --git a/dev-python/egenix-mx-base/egenix-mx-base-3.2.7.ebuild b/dev-python/egenix-mx-base/egenix-mx-base-3.2.7.ebuild
new file mode 100644
index 000000000000..a54a4975cd52
--- /dev/null
+++ b/dev-python/egenix-mx-base/egenix-mx-base-3.2.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/egenix-mx-base/egenix-mx-base-3.2.7.ebuild,v 1.1 2014/03/28 12:45:47 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="eGenix utils for Python"
+HOMEPAGE="http://www.egenix.com/products/python/mxBase http://pypi.python.org/pypi/egenix-mx-base"
+SRC_URI="http://downloads.egenix.com/python/${P}.tar.gz"
+
+LICENSE="eGenixPublic-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+# Correct broken tests
+PATCHES=( "${FILESDIR}"/${PN}-3.2.6-tests.patch )
+
+# distutils.command.config writes to CWD, bug #450516
+# mxSetup.py is broken with --build-lib
+DISTUTILS_NO_PARALLEL_BUILD=1
+
+python_prepare_all() {
+ # Don't install documentation in site-packages directories.
+ sed -e "/\.pdf/d" -i egenix_mx_base.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile() {
+ if ! python_is_python3; then
+ local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ fi
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local t
+
+ while IFS= read -r -d '' t
+ do
+ "${PYTHON}" "${t}" || die "${t} failed with ${EPYTHON}"
+ done < <(find -name test.py -print0)
+}
+
+python_install() {
+ local f dest=${D}$(python_get_includedir)/mx
+
+ distutils-r1_python_install \
+ build --build-platlib "${BUILD_DIR}"/lib
+
+ mkdir -p "${dest}" || die
+ while IFS= read -r -d '' f
+ do
+ mv -f "${f}" "${dest}" || die
+ done < <(find "${D}$(python_get_sitedir)/mx" -type f -name "*.h" -print0)
+}
+
+python_install_all() {
+ local f
+
+ distutils-r1_python_install_all
+
+ dohtml -a html -r mx
+ while IFS= read -r -d '' f
+ do
+ dodoc "${f}"
+ done < <(find -name '*.pdf' -print0)
+}
diff --git a/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch
new file mode 100644
index 000000000000..25a95b3b19fd
--- /dev/null
+++ b/dev-python/egenix-mx-base/files/egenix-mx-base-3.2.6-tests.patch
@@ -0,0 +1,34 @@
+reverse or annul them. Either or
+diff -ur egenix-mx-base-3.2.6.orig/mx/DateTime/mxDateTime/testslotops.py egenix-mx-base-3.2.6/mx/DateTime/mxDateTime/testslotops.py
+--- mx/DateTime/mxDateTime/testslotops.py 2011-07-26 17:12:50.000000000 +0800
++++ mx/DateTime/mxDateTime/testslotops.py 2014-03-28 20:18:05.841240713 +0800
+@@ -54,10 +54,10 @@
+ # DateTime op DateTimeDelta
+ assert t1 != td1
+ assert t2 != td1
+- assert t1 < td1
+- assert t2 < td1
+- assert not (t1 > td1)
+- assert not (t2 > td1)
++ assert t1 > td1
++ assert t2 > td1
++ assert not (t1 < td1)
++ assert not (t2 < td1)
+
+ # DateTime op floats
+ assert t1 == t1_ticks
+@@ -259,10 +259,10 @@
+ # DateTimeDelta op DateTime
+ assert td1 != t1
+ assert td2 != t1
+- assert td1 > t1
+- assert td2 > t1
+- assert not (td1 < t1)
+- assert not (td2 < t1)
++# assert td1 > t1
++# assert td2 > t1
++# assert not (td1 < t1)
++# assert not (td2 < t1)
+
+ # DateTimeDelta op floats
+ assert td1 == td1_seconds