summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-05-25 15:52:56 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-05-25 15:52:56 +0000
commit0e59a04c0d21c22c5509896983fea96e72b2e1bb (patch)
treeff39db94bbf597db6164a926f01535cefe08f766
parentalpha/ia64/sparc/x86 stable wrt security #223017 (diff)
downloadgentoo-2-0e59a04c0d21c22c5509896983fea96e72b2e1bb.tar.gz
gentoo-2-0e59a04c0d21c22c5509896983fea96e72b2e1bb.tar.bz2
gentoo-2-0e59a04c0d21c22c5509896983fea96e72b2e1bb.zip
Bump to 3.5. Fixes bug #221273.
(Portage version: 2.1.5.2)
-rw-r--r--app-editors/levee/ChangeLog10
-rw-r--r--app-editors/levee/files/levee-3.5-QA.patch76
-rw-r--r--app-editors/levee/levee-3.4o.ebuild4
-rw-r--r--app-editors/levee/levee-3.5.ebuild32
-rw-r--r--app-editors/levee/metadata.xml2
5 files changed, 119 insertions, 5 deletions
diff --git a/app-editors/levee/ChangeLog b/app-editors/levee/ChangeLog
index 6c2e057d504d..6c6e63eaaa58 100644
--- a/app-editors/levee/ChangeLog
+++ b/app-editors/levee/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/levee
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.13 2007/05/13 18:20:02 bangert Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/ChangeLog,v 1.14 2008/05/25 15:52:56 loki_val Exp $
+
+*levee-3.5 (25 May 2008)
+
+ 25 May 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/levee-3.5-QA.patch, metadata.xml, +levee-3.5.ebuild:
+ Bump to 3.5. Fixes bug #221273.
13 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add herd
diff --git a/app-editors/levee/files/levee-3.5-QA.patch b/app-editors/levee/files/levee-3.5-QA.patch
new file mode 100644
index 000000000000..81052284bb12
--- /dev/null
+++ b/app-editors/levee/files/levee-3.5-QA.patch
@@ -0,0 +1,76 @@
+diff -NrU5 levee-3.5.old/configure.inc levee-3.5/configure.inc
+--- levee-3.5.old/configure.inc 2008-04-12 08:43:13.000000000 +0200
++++ levee-3.5/configure.inc 2008-05-10 17:24:51.000000000 +0200
+@@ -1073,11 +1073,11 @@
+ else
+ PROG_INSTALL="$DEST"
+ fi
+
+ AC_SUB 'INSTALL' "$PROG_INSTALL"
+- AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -s -m 755"
++ AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -m 755"
+ AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 444"
+
+ # finally build a little directory installer
+ # if mkdir -p works, use that, otherwise use install -d,
+ # otherwise build a script to do it by hand.
+diff -NrU5 levee-3.5.old/editcor.c levee-3.5/editcor.c
+--- levee-3.5.old/editcor.c 2008-04-12 08:43:13.000000000 +0200
++++ levee-3.5/editcor.c 2008-05-10 18:32:33.000000000 +0200
+@@ -17,10 +17,11 @@
+ * WARRANTIES OF MERCHANTIBILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE.
+ */
+ #include "levee.h"
+ #include "extern.h"
++#include <stdlib.h>
+
+ /* do some undoable modification */
+
+ /* These variables make docommand nonrecursive */
+
+@@ -172,10 +173,12 @@
+ return(putback(curr, &newend));
+ }
+
+ bool PROC
+ execute(start, end)
++int start;
++int end;
+ {
+ int tf;
+ FILE *f;
+ char scratch[20];
+ bool ret = FALSE;
+diff -NrU5 levee-3.5.old/globals.c levee-3.5/globals.c
+--- levee-3.5.old/globals.c 2008-04-12 08:43:13.000000000 +0200
++++ levee-3.5/globals.c 2008-05-10 18:14:21.000000000 +0200
+@@ -250,11 +250,11 @@
+ {"ignorecase","ic", VBOOL, 0, (void*)&ignorecase },
+ {"bell", "", VBOOL, 0, (void*)&bell },
+ #if OS_ATARI
+ {"mapslash", "ms", VBOOL, 0, (void*)&mapslash },
+ #endif
+- {NULL}
++ {0, 0, 0, 0, 0}
+ };
+
+ /* For movement routines */
+ int setstep[2] = {-1,1};
+
+diff -NrU5 levee-3.5.old/main.c levee-3.5/main.c
+--- levee-3.5.old/main.c 2008-04-12 08:43:13.000000000 +0200
++++ levee-3.5/main.c 2008-05-10 18:08:14.000000000 +0200
+@@ -277,11 +277,11 @@
+ #if OS_ATARI
+ long _STKSIZ = 4096;
+ long _BLKSIZ = 4096;
+ #endif
+
+-void /* should be union { void a; int b; float c; } to annoy the purists */
++int
+ main(argc,argv)
+ int argc;
+ char **argv;
+ {
+ initialize(argc, argv);
diff --git a/app-editors/levee/levee-3.4o.ebuild b/app-editors/levee/levee-3.4o.ebuild
index e9d02c9adabc..5a2f35102c56 100644
--- a/app-editors/levee/levee-3.4o.ebuild
+++ b/app-editors/levee/levee-3.4o.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.4o.ebuild,v 1.18 2006/05/12 01:30:38 tcort Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.4o.ebuild,v 1.19 2008/05/25 15:52:56 loki_val Exp $
IUSE=""
diff --git a/app-editors/levee/levee-3.5.ebuild b/app-editors/levee/levee-3.5.ebuild
new file mode 100644
index 000000000000..f7e984204844
--- /dev/null
+++ b/app-editors/levee/levee-3.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/levee/levee-3.5.ebuild,v 1.1 2008/05/25 15:52:56 loki_val Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="Really tiny vi clone, for things like rescue disks"
+HOMEPAGE="http://www.pell.chi.il.us/~orc/Code/"
+SRC_URI="http://www.pell.chi.il.us/~orc/Code/levee/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="levee"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+IUSE=""
+DEPEND="sys-libs/ncurses"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-QA.patch
+}
+
+src_compile() {
+ ./configure.sh --prefix=/usr || die "configure failed"
+ emake CFLAGS="${CFLAGS} -Wall -Wextra ${LDFLAGS}" \
+ CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake PREFIX="${D}" install || die "emake install failed"
+}
diff --git a/app-editors/levee/metadata.xml b/app-editors/levee/metadata.xml
index 54494c4bb860..8d0845a7e6aa 100644
--- a/app-editors/levee/metadata.xml
+++ b/app-editors/levee/metadata.xml
@@ -3,6 +3,6 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
-<email>maintainer-needed@gentoo.org</email>
+<email>loki_val@gentoo.org</email>
</maintainer>
</pkgmetadata>